Hello Guest it is March 06, 2021, 06:11:50 AM

Author Topic: Help!!!... New to Mach3... Read and watched the tutorial...  (Read 3005 times)

0 Members and 1 Guest are viewing this topic.

Offline OTB

*
  •  5 5
    • View Profile
Help!!!... New to Mach3... Read and watched the tutorial...
« on: February 29, 2012, 06:57:09 PM »
Hey guys I am new to mach3 but have used cnc machines before.

I am using the TB6560 4 axis driver board. But it does not look 100% to the picture on its documentation. I think it may be an earlier version and if so does anyone know if the Pinout is the same?

I am also using a 4 wire KL23H284-35-4b servo motor setup to run a mini mill.

Wire diagram says black to A+, Green to A-, Red to B+, and Blue to B-

I connected everything and mach3 recognizes the driver board in the printer port...

My Problem.

After setting everything up to the pinouts given to me via the english translation of the board.

the motors move but in only one direction and sometimes it will do the reversal but always one direction and either x or y axis and z is always on.

In the jog interface it does not matter if i press x+ or x- it will only go one way... then y wont do anything... and z will only go one way if + or - is pressed... and if the software is rebooted it does the same thing but x wont do anything and y will do the same thing...

Any takers? Ive been fighting this for 2 days so far and even read the whole tutorial... I think the pins are wrong but the pinout i have came with it and is the only one i can find... the board looks the same as the pic except the power in is on the opposite side and the diodes the axis connects to does not have a capacitor but the pic does...

Thanks in advance...

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Help!!!... New to Mach3... Read and watched the tutorial...
« Reply #1 on: March 01, 2012, 03:20:49 AM »
Attach your xml and a link to, or the documentation you have on the board.
Hood

Offline OTB

*
  •  5 5
    • View Profile
Re: Help!!!... New to Mach3... Read and watched the tutorial...
« Reply #2 on: March 01, 2012, 04:00:53 PM »
how do i extract the xml? i took a pic of the board but am having a hard time uploading it.

Offline OTB

*
  •  5 5
    • View Profile
Re: Help!!!... New to Mach3... Read and watched the tutorial...
« Reply #3 on: March 01, 2012, 04:02:13 PM »
here is the pic of the board.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Help!!!... New to Mach3... Read and watched the tutorial...
« Reply #4 on: March 01, 2012, 04:18:50 PM »
Open Mach and look at the lower right to see the name of the profile you are using. Next close Mach then browse to your Mach folder and look for a file with that name and a xml extension. Copy it to your desktop and rename to OTB.xml then attach to the forum.
Hood

Offline OTB

*
  •  5 5
    • View Profile
Re: Help!!!... New to Mach3... Read and watched the tutorial...
« Reply #5 on: March 01, 2012, 06:26:37 PM »
here it is. thanks for helping me with this... been such a headache.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Help!!!... New to Mach3... Read and watched the tutorial...
« Reply #6 on: March 02, 2012, 02:50:52 AM »
Have sent you a pm.
Hood