Hello Guest it is January 29, 2020, 08:41:03 AM

Author Topic: vista spindle tach not showing up in rpm box  (Read 2377 times)

0 Members and 1 Guest are viewing this topic.

vista spindle tach not showing up in rpm box
« on: February 07, 2012, 12:46:32 AM »
I'm using a 6axis blue screenset.

The spindle tach looks like it's working, but rpm value does not show in display. Apparently a known Mach bug?

Any help?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: vista spindle tach not showing up in rpm box
« Reply #1 on: February 07, 2012, 03:36:46 AM »
Do you have the Index input set correctly?
Do you have the Spindle relays enabled?
Are you calling a M3 or M4 to start the spindle?
What do you have for Index Debounce?
Hood
Re: vista spindle tach not showing up in rpm box
« Reply #2 on: February 08, 2012, 12:26:03 AM »
I was told to try the newest version of Mach by spindle tach supplier.

So I don't screw up my working machine, is there a tutorial or steps to installing the latest Mach version without screwing up all my settings? I think I have version .022? don't know how to check that

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: vista spindle tach not showing up in rpm box
« Reply #3 on: February 08, 2012, 03:30:28 AM »
Open Mach and look at your main page lower right and you will see the name of the profile you are using. Close Mach and go to the Mach3 folder and look for a file of that name with an xml extension, copy it to another location. Also save the brains folder if you have any made , the macro folder of the profile you are using, the plugins folder if you are using any and lastly if using a custom screenset save it and any images. Oh one more, your licence file, its called Mach1Lic.dat and is in the Mach3 folder.
Once you have all of that backed up then you will have no problems upgrading as if anything goes wrong its just a case of copying the files back.
To actually upgrade its as simple as starting the exe you downloaded and letting it install.

However you never answered the questions I asked, for the spindle speed to be seen by Mach these conditions need to be met.
Hood
Re: vista spindle tach not showing up in rpm box
« Reply #4 on: February 08, 2012, 09:57:09 AM »
The sensor runs off of usb port, manufacturer also includes a plugins file.
Re: vista spindle tach not showing up in rpm box
« Reply #5 on: February 08, 2012, 08:55:06 PM »
had version .020, upgraded to version .058 and now rpm displays like it should.

haven't checked all functions yet, but all I did was DL new version. everything seems to work fine. My mach screen isn't maximized though.