Hello Guest it is May 25, 2019, 07:59:30 AM

Author Topic: How to set Mach3-config file for millimeter instead of inch  (Read 18354 times)

0 Members and 1 Guest are viewing this topic.

How to set Mach3-config file for millimeter instead of inch
« on: January 17, 2012, 04:19:31 AM »
Hi,

Could someone instruct me on what entry to set in the config file, for Mach3 to start up with
millimeter setting instead of inch

Regads
stab :)

Offline Hood

*
  •  25,817 25,817
  • Carnoustie, Scotland
    • View Profile
Re: How to set Mach3-config file for millimeter instead of inch
« Reply #1 on: January 17, 2012, 04:22:59 AM »
Config menu then set native units and choose mm. You will need to adjust your steps per unit if you already have them set per inch.

Hood
Re: How to set Mach3-config file for millimeter instead of inch
« Reply #2 on: January 17, 2012, 05:08:43 AM »
What entry would that be and is it just a recalculation according to the ratio 25.4(mm) / 1(inch)?

stab

Offline Hood

*
  •  25,817 25,817
  • Carnoustie, Scotland
    • View Profile
Re: How to set Mach3-config file for millimeter instead of inch
« Reply #3 on: January 17, 2012, 05:18:40 AM »
It would be the steps per unit from Config menu then Motor tuning. If you already have that set to steps per inch then you need to divide by 25.4 to get steps per mm also the Velocity will need multiplied by 25.4 and likewise the Acceleration. You will need to press the save axis button before you move to the next.
If it is not already set up then just calculate the steps per unit to be equal to steps per mm.
Hood
Re: How to set Mach3-config file for millimeter instead of inch
« Reply #4 on: January 18, 2012, 02:15:36 PM »
Hi again,

Thanks for replying.
Tried your suggestion with "Config menu then set native units" but I get a warning-message:
Do NOT use this to change between Metric and English GCode. This is for setting ther units for motor tuning.

I'm using Mach3 Version R3.043.022 and in the config drop-down I don't find any entry indicating a way to
set millimeters as default.

Offline Hood

*
  •  25,817 25,817
  • Carnoustie, Scotland
    • View Profile
Re: How to set Mach3-config file for millimeter instead of inch
« Reply #5 on: January 18, 2012, 02:25:24 PM »
That message is telling you that it is the way to set Mach to metric as default but that it is NOT the way to change if you are simply wanting to run metric code on an inch setup machine.
Hood
Re: How to set Mach3-config file for millimeter instead of inch
« Reply #6 on: January 27, 2012, 08:36:34 PM »
HI, (Newbie trying to convert K40 chinese laser using Lightobject 2 axis board and Mach3 or KCam)

I can't get machine ( in Mach3 ) to run in metric units....displays in inches and travels in inches !
I have read all the posts I can find, changed config to mm....dxf file loaded in mm ....but still reads and travels in inches !
What am I missing ???
Thanks..........

Offline Hood

*
  •  25,817 25,817
  • Carnoustie, Scotland
    • View Profile
Re: How to set Mach3-config file for millimeter instead of inch
« Reply #7 on: January 28, 2012, 03:49:37 AM »
You need to set your steps per unit so that when you ask for a 1mm move it moves 1mm.
Hood