Hello Guest it is July 12, 2020, 12:18:44 AM

Author Topic: mach3 problem  (Read 3799 times)

0 Members and 1 Guest are viewing this topic.

mach3 problem
« on: January 16, 2012, 03:23:31 PM »
if  I load g-code  to mach 3 and I press  start button 

 This gives me a message


softlimit .worning..continue?
     yes     NO


what this message means  thanks for reply

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: mach3 problem
« Reply #1 on: January 16, 2012, 03:32:42 PM »
It means the code is going beyond the softlimits you have set. If this is a lathe then it will always throw that message even if the code will be within soft limits, it is on the list to be fixed but its not top priority.
Hood
Re: mach3 problem
« Reply #2 on: January 16, 2012, 03:41:06 PM »
This is a milling machine and I had never this problem

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: mach3 problem
« Reply #3 on: January 16, 2012, 03:45:00 PM »
Is your code maybe taking it without the softlimits you have set?
Do you possibly have a G90 and G28 on the same line?
Hood
Re: mach3 problem
« Reply #4 on: January 16, 2012, 04:08:24 PM »
This problem can spoil my part? what I cutting out

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: mach3 problem
« Reply #5 on: January 16, 2012, 04:11:15 PM »
Attach your code and your xml and I will have a look and see if I can find the problem.
Hood
Re: mach3 problem
« Reply #6 on: January 16, 2012, 04:24:32 PM »
  g-code
« Last Edit: January 16, 2012, 04:29:07 PM by komar1970 »

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: mach3 problem
« Reply #7 on: January 16, 2012, 04:35:36 PM »
I do not get a soft limit warning here so it has to be a setting you have in Mach, please attach your xml.
Hood
Re: mach3 problem
« Reply #8 on: January 16, 2012, 04:56:50 PM »
file

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: mach3 problem
« Reply #9 on: January 17, 2012, 02:59:38 AM »
You do not have softlimits set up as the settings are still default. You should turn off oft limits on the main screen or set the correct values for your table area from Config menu then Homing and limits.
Hood