Hello Guest it is May 08, 2021, 03:51:05 PM

Author Topic: setting z tool height with the mach internal MPG strange behaviour  (Read 6436 times)

0 Members and 1 Guest are viewing this topic.

Offline nava

*
  •  45 45
    • View Profile
So in preparing the z height for the my tools 0 starting point with the mach3 internal mpg I'm having some strange issues I cant figure out.

Steps to reproduce

1.  I jog down to set the Z height using the internal mach3 mpg while at the same time measuring with a dial gauge(used 2 different ones at the same time)
2. Both dials read 0 and then I set z to 0(OK should now be zero)
3.  Pressing goto 0 should now return the dial gauges to 0 but instead the dials move .03mm past 0.
4.  Pressing goto 0 again returns the dials to 0.03mm
I can repeat step 4 over and over again and the dials always return to the same .03 position.  I have inputeed my backlash a few months ago(.07mm) and because the dials return to the same .03 past z 0 positron I think the backlash calculated correctly.
I also tried jogging the tool down past the dials 0 then jogging it back up to 0 before i set the soft zero on the z.  If I'm jogging up to z then when i hit goto 0 the tool is .01mm below 0.

I cant really understand whats going on here but obviously it isn't that great for setting up my tool positions.
Any insight to what may be going on would be wonderful.

I also have the same error when using my xbox controller as my mpg:( And if it helps I still have it plugged in while using the mach3 internal mpg

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: setting z tool height with the mach internal MPG strange behaviour
« Reply #1 on: January 13, 2012, 08:12:10 AM »
Try with backlash disabled.
What are your steps per unit on Z?
Hood

Offline nava

*
  •  45 45
    • View Profile
Re: setting z tool height with the mach internal MPG strange behaviour
« Reply #2 on: January 13, 2012, 08:25:48 AM »
My Z is 400 steps per mm.
Ill try with the backlash disabled..itching to finish work now and get back to the shop:)

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: setting z tool height with the mach internal MPG strange behaviour
« Reply #3 on: January 13, 2012, 08:35:43 AM »
Ok thats fine, was just wondering if you were really course on the Z but thats not the case.
Hood

Offline nava

*
  •  45 45
    • View Profile
Re: setting z tool height with the mach internal MPG strange behaviour
« Reply #4 on: January 13, 2012, 08:48:49 AM »
Im just thinking more about it and I guess I cant get my head around why the goto 0 works after the first set..reaptedly goes back to where it thinks z is.  I must have pressed goto 0 about 30 times and its returning to the same position on the dial everytime. My thought is that perhaps the backlash is calculated a little differnt for the mpg.  Anyway Ill try to disable the backlash when im there in 2 hours or so.

Offline nava

*
  •  45 45
    • View Profile
Re: setting z tool height with the mach internal MPG strange behaviour
« Reply #5 on: January 14, 2012, 11:31:37 AM »
Ok so had time to test with backlash diabled (allways restarted mach before retesting also tried restarting my control box).  Changing the backlash had no effect at all apart froom i can her the %50 speed kick but goto 0 returns to 0 on my dial..which is odd.  I even tried testing if backlash comp was working at all by setting it to 5mm and again I can hear the motors speed change but still returns to 0 the dial.  I played with my jog speed in the mpg and when slow jog is on anything else than 100% I get little errors +- .01mm...if I leave it on 100% to set the Z it returns to the dail spot on..its strange for me because I remember setting the backlash comp up parts come out within spec.  But now Im even more unsure that Ill be able to reset backlash again. 

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: setting z tool height with the mach internal MPG strange behaviour
« Reply #6 on: January 14, 2012, 11:47:09 AM »
Not sure what you are saying, its working correctly now or not?
Can you attach your xml please and I will have a look at the settings and see if I can find an issue.
Hood

Offline nava

*
  •  45 45
    • View Profile
Re: setting z tool height with the mach internal MPG strange behaviour
« Reply #7 on: January 14, 2012, 12:00:41 PM »
its not working correctly as backlash doesnt seem to come into effect so I cant really test it.  The machine returns to 0 even though it should evershoot with backlash set to 5mm..and if BLC is off the dail and th dro also return to 0.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: setting z tool height with the mach internal MPG strange behaviour
« Reply #8 on: January 14, 2012, 02:34:22 PM »
Not sure what is going on then.
I do see you have the A of MPG set to same port and pins as Z Limit/Home and the B is set to the same port and pin as the E-Stop. Thats not correct and may cause you issues.
Do you have a MPG connected?
Hood

Offline nava

*
  •  45 45
    • View Profile
Re: setting z tool height with the mach internal MPG strange behaviour
« Reply #9 on: January 14, 2012, 02:47:53 PM »
I have an xbox conroller with the plugin but no other mpg.  I'm also not sure how those other setting are wrong as the XML was given to me by the company that made the Cnc conversion..what should I do to the settings to change it?  Thanks for your help:)