Hello Guest it is November 13, 2019, 05:58:28 PM

Author Topic: limits tripping  (Read 2853 times)

0 Members and 1 Guest are viewing this topic.

limits tripping
« on: December 27, 2011, 08:28:51 AM »
Hi all I have got a problem I hope you can help with. I can run my CNC router with Mach3 without a problem without the spindle running but when I wind up the spindle the emergancy stop comes on and Mach3 says that a limit switch has been actuated. but none of the lights in the diagnostics screen come on. I think it is due to electrical noise. Anyone had this problem.
Bob

Offline Tweakie.CNC

*
  • *
  •  7,986 7,986
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: limits tripping
« Reply #1 on: December 27, 2011, 09:16:55 AM »
Hi Bob,

Yes I think it is electrical noise as well.

Lots of people have had this same problem and the cures have turned out to be various. A forum search should turn up lots of information but try re-routing your spindle cable away from other wiring, make sure you don't have any 'earth loops' or 'GND loops' and if you are using a VFD that it is properly earthed (at one point only).

Just a couple of things to try.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: limits tripping
« Reply #2 on: December 27, 2011, 09:17:00 AM »
Yes thousands of people have, usually caused by noise as you suspect or sometimes vibration if the limit switches are poor quality. The solution is to make sure your wiring, especially limits, are shielded and properly grounded to a single point. You can also try increasing the Debounce Interval on General Config, try 2000 and work down again until it stops. Best to shield correctly though as  setting debounce is just hiding the problem rather than curing it.

Ideal solution is 24v on your limits etc as its more imune to noise  but thats obviously more involved.
Hood
Re: limits tripping
« Reply #3 on: December 27, 2011, 09:19:01 AM »
Thanks Tweakie
 I will look for some tips
Bob
Re: limits tripping
« Reply #4 on: December 28, 2011, 02:32:02 AM »
Hi Hood
Thanks for that  I was thinking of using a totally separate power supply and some opto isolators for a circuit. I think I will go down that road now.
Bob
PS I switched off the limits  in Mach 3 and the router works like a dream.
Bob
« Last Edit: December 28, 2011, 02:36:07 AM by redpiperbob »
Re: limits tripping
« Reply #5 on: December 28, 2011, 03:14:38 AM »
Bob,
Before you go to a lot of work and expense rewiring your limit switch circuit, try adding a small ceramic capacitor (.1uf/.01uf) between the limit switch input connection and ground on your controller/bob board.
Regards,
John Champlain
www.picengrave.com
 
Re: limits tripping
« Reply #6 on: December 28, 2011, 04:33:06 AM »
Thanks John will do
Bob
Re: limits tripping
« Reply #7 on: January 09, 2012, 02:53:03 AM »
Hi John
Did what you said . All working now .  ;D  ;D
Thanks
Bob