Hello Guest it is July 23, 2019, 01:51:43 AM

Author Topic: Steppers are too slow  (Read 32877 times)

0 Members and 1 Guest are viewing this topic.

Re: Steppers are too slow
« Reply #30 on: December 05, 2011, 07:46:26 AM »
Hi Sargon - can you explain this a bit more please. I just don't get how a current limiting device (a chopper in this case) would LIMIT current to LESS than it was set to. (Not to be confused with not being ABLE to drive the "set" current after the motor reaches stall speed).

I'm not sure I understand the question. I don't think I said a chopper would "limit" the current to less than the max setting. That doesn't mean the stepper will always draw maximum current. Of course, once the stepper has stalled the power coupling between the rotor and stator will drop off to almost nothing - the motor will, at that point, only be able to provide a small fraction of it's normal torque.

On an aside, after re-reading the post I did mis-speak in calling, or at least alluding to the idea that a chopper is a constant voltage source - which isn't true. The chopper is being fed constant voltage and then typically uses PWM to "chop" the power into pulses in an attempt to provide constant current - with limited success when compared to a linear supply.

If there are any errors here please don't hesitate to correct me! I'm always willing to learn, and I'm not an electrical engineer so I will admit that my understanding of the theory may not be complete or necessarily correct.


Tweakie:
Please specify what you think would be acceptable capacitance, and what would be considered too large. If I were to use a capacitor for this purpose I would be thinking somewhere in the range of 100uF - 500uF. Am I correct? Also, thank you for clarifying where the problem is in using too much capacitance - makes sense to me - can't respond to changing conditions if you can't see them.

Online Tweakie.CNC

*
  • *
  •  7,851 7,851
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Steppers are too slow
« Reply #31 on: December 05, 2011, 08:19:02 AM »
My advice would be not to add any additional capacitor at all.  ;)

I hadn't really thought about this until I tried it but as far a bipolar stepper motors are concerned rotating an un-energised motor by hand has some magnetic resistance - drive the stepper beyond it's stall point and it is perfectly free to rotate by hand in either direction without any of the previously felt magnetic resistance.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Steppers are too slow
« Reply #32 on: December 05, 2011, 12:09:23 PM »
Just a note Guys,

Do not fit a large capacitor across the output of a switched mode power supply it affects the sense response.

Tweakie.
Hi Tweakie - I have a slight feeling of deja vu here because Mariss used to have a section in the now famous STEP MOTOR BASICS guide on how important it was to have fuses between the PS and the drives. From what I understand this practice is now apparantly regarded as a complete no no. So I'm quite prepared to accept that the section in question re: caps on switch mode supplies has probably been withdrawn for the same reason. Mariss wrong twice? - next I'll be finding out there's no freakin' Santa  :'(

It'll be a while before I quote from that particular tome again....

Ian

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Steppers are too slow
« Reply #33 on: December 05, 2011, 04:47:13 PM »
I'm not sure I understand the question. I don't think I said a chopper would "limit" the current to less than the max setting. That doesn't mean the stepper will always draw maximum current.
This and your earlier comment that load affects current is what I don't get. As I understand it, the chopper by it's very nature is monitoring the current through the motor. ONLY when the current through the motor reaches the set point will the chopper start to chop. (There will of course come the time with motor speed when the voltage simply can't drive the required current because of inductance and ultimately the motor will stall but that's not what we're talking about here). I can see no reason how external mechanical load can affect the current through the motor. Servos yes but steppers no. Maybe I'm wrong.

Ian

Offline RICH

*
  • *
  •  7,342 7,342
    • View Profile
Re: Steppers are too slow
« Reply #34 on: December 05, 2011, 05:20:04 PM »
I have G201's and have an in line fuse upstream of each of the drives. The fuse is a fast blow and are below the max 7A rating of the drive. Have only blown a fuse one time and that was when the controller was turned on. Non regulated power supply here is capable of 30amps. You all may do as you wish but i will keep the fuses in mine.  ;)

RICH
Re: Steppers are too slow
« Reply #35 on: December 05, 2011, 06:30:03 PM »
Hi Stuart,

you have the same China maid BoB as i have, and the same problem too. I had to replace both 74hc14 chips and it works perfect after that. Recently i purchased 2 more BoB from same the vendor at Ebay....... both got the same problem as my first BoB.

Regards
Stein
Re: Steppers are too slow
« Reply #36 on: December 05, 2011, 11:25:26 PM »
This and your earlier comment that load affects current is what I don't get. As I understand it, the chopper by it's very nature is monitoring the current through the motor. ONLY when the current through the motor reaches the set point will the chopper start to chop. (There will of course come the time with motor speed when the voltage simply can't drive the required current because of inductance and ultimately the motor will stall but that's not what we're talking about here). I can see no reason how external mechanical load can affect the current through the motor. Servos yes but steppers no. Maybe I'm wrong.

Ian

No, I don't believe you're wrong. I was mixing up theory. My mistake for sure. Power consumed by the motor can drop with increased load, not current. Current should be constant as long as there is sufficient voltage to drive it through the inductance of the motor (Back EMF related). Thank you for correcting me. I really shouldn't get into theory at 5am - brain just doesn't quite think things through like it does later in the day. This lesson will surely make the point stick in my mind - embarrassment is a powerful learning tool, after all.
Re: Steppers are too slow
« Reply #37 on: December 06, 2011, 04:20:11 AM »
Hi Stein,
When you say you had the same problems as I have had, are you referring to the port being U/S or the slow stepper motor issue? (Or both)

Stuart

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Steppers are too slow
« Reply #38 on: December 06, 2011, 04:58:14 AM »
I have G201's and have an in line fuse upstream of each of the drives. The fuse is a fast blow and are below the max 7A rating of the drive. Have only blown a fuse one time and that was when the controller was turned on. Non regulated power supply here is capable of 30amps. You all may do as you wish but i will keep the fuses in mine.  ;)

RICH
On an older rig I have G201's also AND I have fast blow fuses as recommended by the STEP MOTOR BASICS guide at the time I bulit the system back in the day. I've never had a fuse blow so I can't comment on the result. I never had an issue with this until a post by Ray in this thread http://www.machsupport.com/forum/index.php/topic,17090.80.html raised the controversy. In this present thread I was just trying to make the point that even the best sources of info can do a 180. Was Mariss correct then or now - who knows?

Moving back to Stuart's issues, (Thanks for your reply BTW Sargon). I was just raising a question about his current readings back in post #24. If these readings are correct then something's very wrong. At standstill, the total coil currents should be 4*3.32A*2/3 = 8.85A NOT the 3.615A Stuart records. HOWEVER if Mariss's statement that a chopper drive "draws" current at 20KHz from the PS is correct then I agree with Sargon's comment about using a multimeter to try to read this is not going to give useful results. So are Stuart's motors being current starved - who knows? IF IF IF there was a cap in there we could read the steady DC between the PS and the cap and get a more meaningful reading but I've learned here that I was wrong and that apparantly caps on switched supplies is not advised so..... just glad I use purpose built unregulated power supplies with hunky caps (and after tossing a coin - no dc fuses  ;D).

Ian
Re: Steppers are too slow
« Reply #39 on: December 06, 2011, 05:18:27 AM »
Stuart,

yea, the problem with port 2 not working, but it looks like the smd-chips have been through a very hot production process and many strange things can happens.

Stein