Hello Guest it is July 20, 2019, 01:45:53 AM

Author Topic: Sherline Lathe only travels half the distance Mach3 reads. HELP!  (Read 5322 times)

0 Members and 1 Guest are viewing this topic.

Offline RS

*
  •  9 9
    • View Profile
Sherline Lathe only travels half the distance Mach3 reads. HELP!
« on: November 09, 2011, 08:01:32 PM »
Hello,
    I am brand new to this and I don't really know what I am doing.  I just bought a Sherline lathe with servo motors and Mach3.  I set up the lathe and everything is working fine except for the fact that when I jog it 1" in Mach3, it only actually travels .5".  It seems that all movement and speeds shown in Mach3 are double what is actually happening on the lathe.  I have searched the forum and found that other people with this problem had to adjust their motor tuning to get it to work right.  I was given a sheet of specs for motor tuning with the lathe for quick setup but obviously it isn't working, if the problem is actually with the motor tuning.  I was hoping somebody could look at these settings and see if they could figure out what I am missing.  I have attached a few of the spec sheets that came with the lathe and a motor tuning and general configuration screenshot.  I can supply any other screenshot you might need.  Below are links to the type of servo drivers and servo motors I have.  I appreciate any help that you can give on setting this up correctly.  Thank you.

RS

http://www.imsrv.com/deskcnc/servospecs.pdf
http://www.cadcamcadcam.com/assemblymotorreducer.aspx

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Sherline Lathe only travels half the distance Mach3 reads. HELP!
« Reply #1 on: November 10, 2011, 02:50:21 AM »
If it only travels half the distance commanded then you need to double the steps per unit of each axis doing so, that is in Motor Tuning.

Hood
Re: Sherline Lathe only travels half the distance Mach3 reads. HELP!
« Reply #2 on: November 10, 2011, 02:59:32 AM »
Hi,

The actual movement of the cross slide will be 1/2 the distance displayed in the X axis. (if you'r working in diameter)
but should move 1:1 in the Z axis.

ATB
Derek
You can "chop it off" but can't "chop it on"
Re: Sherline Lathe only travels half the distance Mach3 reads. HELP!
« Reply #3 on: November 10, 2011, 09:10:07 AM »
Can't ya just run the Axis calibration on the settings page and measure it. That way Mach will determine the steps per for you...  I do it all the time and it works great. One tip tho, if you first go to the motor tuning page and set your rapid speed to say ten or something small, when you setup for the auto axis calibration and have your DTI on the movement to measure actually how far the axis moved it is easier to read how far it actually went without getting lost.  I usually use my 0-1" dial indicator and set it for say .5" of travel. Then I hit okay and watch it and count the number of times the needle goes around. That way you can easily tell how far you actually went without having to stare at the little needles all day. Then once you are close set it for say 1" and rerun it. That should get you close enough to fine tune it from there. Good luck and peace


Pete

Re: Sherline Lathe only travels half the distance Mach3 reads. HELP!
« Reply #4 on: November 10, 2011, 11:00:16 AM »
do you have the "sherline 1/2 pulse mode" checked in ports and pins?

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Sherline Lathe only travels half the distance Mach3 reads. HELP!
« Reply #5 on: November 12, 2011, 05:29:08 PM »
This setting, the way I understand it just lengthens the signals duration. It has no effect on distance traveled.
do you have the "sherline 1/2 pulse mode" checked in ports and pins?
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Sherline Lathe only travels half the distance Mach3 reads. HELP!
« Reply #6 on: November 12, 2011, 05:35:03 PM »
Though RS doesnt seem to have reponded and IMU this would have no effect on distance traveled, did anybody else notice his Z axis motor tuning the step pulse was 0? Is this normal in a Servo system? I wouldnt think the the controller would see the pulse but I have been wrong plenty of times.
« Last Edit: November 12, 2011, 05:36:58 PM by Fastest1 »
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Sherline Lathe only travels half the distance Mach3 reads. HELP!
« Reply #7 on: November 13, 2011, 03:36:01 AM »
All my machines ran at pulse width of zero when I used the parallel port. Its not actually zero however as there is the latency of your computer to consider and the pulse width setting is just an extra on top of that. What you will need there depends on the drives and computer you have.
If the OP has Sherline chosen then it wouldnt matter what was there anyway as Mach would ignore that and set the pulse width to 40.
Hood

Offline RS

*
  •  9 9
    • View Profile
Re: Sherline Lathe only travels half the distance Mach3 reads. HELP!
« Reply #8 on: February 07, 2012, 09:54:16 AM »
Hey Everyone,
     I apologize for not following up on this post earlier.  Hood was correct with his first post.  I doubled the steps per unit and it fixed the problem. Now that I have read the other posts, I have a few other questions.  Should I have the sherline 1/2 pulse mode checked?  And regarding the other post by Fastest1 and Hood, I bought a USB Smoothstepper and a laptop for the lathe that will arrive soon, will I need to make changes in the motor tuning to get that to work?  Thank you. RS

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Sherline Lathe only travels half the distance Mach3 reads. HELP!
« Reply #9 on: February 07, 2012, 11:35:06 AM »
If you are using sherline drives then you will likely need the half pulse, if using another brand then possibly not.
Regards the SS no you shouldnt need to retune.
Hood