Hello Guest it is May 25, 2019, 05:34:27 AM

Author Topic: Toolchange in turn R3.043.050 not working as suppose to  (Read 1835 times)

0 Members and 1 Guest are viewing this topic.

Toolchange in turn R3.043.050 not working as suppose to
« on: November 05, 2011, 08:43:57 AM »
Hello.
Using the latest version R3.043.050, and using the standard toolchange format Tyyxx, where yy is the toolpost number and the xx is the offset number, for example:

T0303 calls tool in post nº3 with offset number 3 (in my case 03 offset is direction 7 and radius 0.8mm)

but calling

T0903 calls tool in post nº9 (as expected) but it also calls the offset nº9 instead of offset number nº3 as it was suppose to, this is the offset that is being used by the DRO's and that appear on the toolpath display is always in relation, not with the offset asked, but it is in reference to the toolpost asked.

Can anyone inform me of a version that have this running ok? My machine only can work if this is corrected.

Thank you
Re: Toolchange in turn R3.043.050 not working as suppose to
« Reply #1 on: November 05, 2011, 09:59:49 AM »
This is then a auto reply, as I tested with others versions and the result was the same.

It seams that Txxyy Mach3 only reads the X and Z offsets of of the tooltable in position yy, and not the tip and radius offsets (that uses from xx). This is not correct and does not follow "standard machine" rules, if this exist (Fanuc Siemens and so on)

When calling Txxyy, the yy should contain date entry for, at least, the following information: tool tip direction, radius, X and Z offset.

Filipe
Re: Toolchange in turn R3.043.050 not working as suppose to
« Reply #2 on: November 11, 2011, 08:31:42 AM »
I have posted this quite some time, without any reply.
There is some place where users send bug reports, where someone is assigned to solve bugs? (this issue is definitely a bug)
 
If this is not done this way, users do not know if bugs or software features will ever be notice, and can be lost in the forum forever, making the software disappointing for anyone that encounters a bug and needs that to be fixed to work properly with the software. For what I see in the forum it seams that there is Mr Art and Mr Brian that do programming, is this correct? Must someone contact them directly inform about program errors?
 
Thank you

Offline BR549

*
  •  6,865 6,865
    • View Profile
Re: Toolchange in turn R3.043.050 not working as suppose to
« Reply #3 on: November 11, 2011, 11:29:31 AM »
That I am aware of that feature has never worked in Mach3 it was never implimented in turn.

I could be wrong about this one(;-)

Best to email Andrew with the question HE is the go to guy for Mach3 support.

(;-) TP
« Last Edit: November 11, 2011, 11:38:25 AM by BR549 »

Offline ger21

*
  • *
  •  6,233 6,233
    • View Profile
    • The CNC Woodworker
Re: Toolchange in turn R3.043.050 not working as suppose to
« Reply #4 on: November 11, 2011, 11:35:07 AM »
Quote
There is some place where users send bug reports, where someone is assigned to solve bugs? (this issue is definitely a bug)

The Yahoo group is the best place to report bugs.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html