Hello Guest it is September 22, 2019, 12:58:50 PM

Author Topic: HELP!! Motor will not move.  (Read 5154 times)

0 Members and 1 Guest are viewing this topic.

HELP!! Motor will not move.
« on: October 22, 2011, 08:08:04 AM »
 I'm new to Mach 3 and having some trouble. Here is what I purchased. All items were purchased from Kelinginc.net
KL-8070D stepper drive
KL34H2120-60-4A motor
c10 breakout board
KL-7212 72V/12A power supply

It appears that I have everything wired correctly but I can not get any motor movement when I jog the x axis. From what I understand I do not need a license for Mach at this point in the game. I just need an X axis for what I'm trying to do.

I have unistalled and reinstalled Mach twice to my computer. When I run the driver test initail everything comes up fine but if I go back in after I put in the correct port info in and run it again it tells me that the pulsing is too fast but then moves forward with the driver test and says excellent. Anyone here have any ideas.

The parralell cable I'm using is a straight through cable. Is this correct?
Re: HELP!! Motor will not move.
« Reply #1 on: October 22, 2011, 08:26:29 AM »
Just thought I would let you know how I had the jumpers set on the breakout board.

2-9 our outputs
com = ground
2-9 = pull up
inputs = pulldown

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: HELP!! Motor will not move.
« Reply #2 on: October 22, 2011, 08:46:25 AM »
Straight through cable is correct and yes demo version works with only a few limitations.
You dont run the driver test when Mach is running, if you are doing that then that is why you get the pulsing too fast message.

When you jog the X do you see the X DRO move in Mach?
Do you have the correct port address set in Mach?
Do you have the port set in Ports and Pins for the axis?
Hood
Re: HELP!! Motor will not move.
« Reply #3 on: October 22, 2011, 09:33:48 AM »
I figured it out. I had the jumper on the board in the wrong spot. I had com set to ground and it should have been 5v. I do have another question though. I need to be able to enter a length into a dro and have the machine move to that spot. can this be done? I know that I can do it on the mdi screen by entering g00x25 for example. I would like to get away from entering the g00x and just enter the length into a dro.

Thanks,
Andy

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: HELP!! Motor will not move.
« Reply #4 on: October 22, 2011, 12:06:21 PM »
No, you need to use MDI or code or jog. Entering a value direct into the DRO will just set the work offset to that position.
Hood
Re: HELP!! Motor will not move.
« Reply #5 on: October 28, 2011, 06:13:29 AM »
@ hood

I 'm also new to mach 3, different case, I hope andy doesn't mine I joint this forum.

when I jog the axis, the DRO run smoothly, (0-1-2-3-4-5------)
when I run with G0 X10  the DRO jump (0-1,1-2,7-4,3-5,9-7,5-9,1---)

what is the cause is this?

pls advise.

thank you

asen