Hello Guest it is January 19, 2022, 09:59:40 PM

Author Topic: Mach3 stops at this line "S100M03"  (Read 5935 times)

0 Members and 1 Guest are viewing this topic.

Mach3 stops at this line "S100M03"
« on: October 18, 2011, 09:32:33 PM »
For some reason when gcode is generated and it contains a "S" command such as "S100M03" the execution stops at this line, If I comment the line out it runs fine.

Any idea how I can fix this so I don't always have to edit that line out.  I use a router so the "S" command doesn't have control over the router anyway.

Thanks

Also I have a new email and cannot find where to update that for this forum.

Hager
Mr. Chips
Retired 3M'r

Offline budman68

*
  • *
  •  2,352 2,352
    • View Profile
Re: Mach3 stops at this line "S100M03"
« Reply #1 on: October 19, 2011, 12:15:39 PM »
For some reason when gcode is generated and it contains a "S" command such as "S100M03" the execution stops at this line, If I comment the line out it runs fine.

Hello, Hager,

I believe editing your post processor is the way to go in this case since you do not need that option. That info should be in your CAM software.

As for your email, go to the top of the page and look for the "Profile" button. That will get you onto your profile page.
Then look to the left where it says: "Account Related Settings" and you should be able to update your email address. Don't forget to input your password and click the "Change Profile" button.

Hoope that helps-
Dave
« Last Edit: October 19, 2011, 12:17:30 PM by budman68 »
----------------------------------------------------------------------
Just because I'm a Global Moderator, don't assume that I know anything !

Dave->    ;)
Re: Mach3 stops at this line "S100M03"
« Reply #2 on: October 19, 2011, 12:25:14 PM »
Thanks Dave

I found the email change utility and will look into how to modify the Post Processor.
Hager
Mr. Chips
Retired 3M'r

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: Mach3 stops at this line "S100M03"
« Reply #3 on: October 19, 2011, 12:44:02 PM »
I don't know of any reason for the CODE "S100M03" to not run, it does here.

Do you get an ERROR message as well??

Can you post the actual line as it appears in the program.

(;-) TP

« Last Edit: October 19, 2011, 12:49:11 PM by BR549 »
Re: Mach3 stops at this line "S100M03"
« Reply #4 on: October 19, 2011, 01:06:52 PM »
Attached a screen shot.
Spindle CW F5 blinks yellow.

Thanks
Hager
Mr. Chips
Retired 3M'r

Offline budman68

*
  • *
  •  2,352 2,352
    • View Profile
Re: Mach3 stops at this line "S100M03"
« Reply #5 on: October 19, 2011, 01:35:55 PM »
Hager,

I see you're using VCarve Pro, what post processor are you using please?

Dave
« Last Edit: October 19, 2011, 01:37:43 PM by budman68 »
----------------------------------------------------------------------
Just because I'm a Global Moderator, don't assume that I know anything !

Dave->    ;)

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: Mach3 stops at this line "S100M03"
« Reply #6 on: October 19, 2011, 01:48:47 PM »
Still works fine here using that code example. When this occurs is the DWELL led flashing on the main screen?

(;-) TP

Offline budman68

*
  • *
  •  2,352 2,352
    • View Profile
Re: Mach3 stops at this line "S100M03"
« Reply #7 on: October 19, 2011, 01:51:20 PM »
Yes, mine works as well here too as I also have VCarve Pro and it puts that into the code as well. This is why I asked which Post Processor he's using.

Dave
----------------------------------------------------------------------
Just because I'm a Global Moderator, don't assume that I know anything !

Dave->    ;)
Re: Mach3 stops at this line "S100M03"
« Reply #8 on: October 19, 2011, 03:53:11 PM »
I picked the first one in the Mach2/3 list.
Mr. Chips
Retired 3M'r

Offline budman68

*
  • *
  •  2,352 2,352
    • View Profile
Re: Mach3 stops at this line "S100M03"
« Reply #9 on: October 19, 2011, 04:54:57 PM »
Hager, try using the Mach2/3 Arcs and see if that runs correctly?

Dave
----------------------------------------------------------------------
Just because I'm a Global Moderator, don't assume that I know anything !

Dave->    ;)