Hello Guest it is October 15, 2019, 08:06:54 AM

Author Topic: New lathe tool turret Help  (Read 7322 times)

0 Members and 1 Guest are viewing this topic.

Re: New lathe tool turret Help
« Reply #10 on: September 05, 2011, 09:25:58 AM »
Yes it is red, have just wired it up and it works ok in manual mode.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: New lathe tool turret Help
« Reply #11 on: September 05, 2011, 12:30:50 PM »
Not got much time and as previously said I am crap at VB, will have a go sometime if no one else helps out but hopefully someone will. I know what needs done but how to put it in VB would take me a lot of trial and error.
Hood
Re: New lathe tool turret Help
« Reply #12 on: September 05, 2011, 12:47:36 PM »
Thanks Hood, is there anyone else who could help with this macro, or adapt an existing one?
Mike
Re: New lathe tool turret Help
« Reply #13 on: September 07, 2011, 05:04:32 AM »
Brian did a macro for an Emco turret posted Oct 2009, is it possible to alter this macro to suit my turret?
Mike

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: New lathe tool turret Help
« Reply #14 on: September 07, 2011, 05:21:37 AM »
Dont know, got a link to it? I have been trying a bit but as VB is a weak point I have not got very far I am afraid :(

Hood
Re: New lathe tool turret Help
« Reply #15 on: September 07, 2011, 05:54:39 AM »
I may have a macro that can be adapted to suit this.
Re: New lathe tool turret Help
« Reply #16 on: September 07, 2011, 08:20:41 AM »
Any help at all would be appriciated.
Mike
Re: New lathe tool turret Help
« Reply #17 on: September 07, 2011, 09:18:10 AM »
Found this in search, entered 'Emco turret' there are several

on: March 04, 2008, 01:06:52 PM 
Started by ToadSprockett, Message by tom_emagRelevance: 3.5%
Thanks, that works great.  Now that I got that going I find that I can't seem to update the current tool number.
 probably wrong format for the command.

Other then that it works fine...

This is on a little EMCO TurnPC lathe with a 6 position tool changer that returns an index and a pulse per tool with
 a single drive signal that causes forward rotation and when dropped reverses rotation to index the tool.

My M6 program is:
---------------------------------------------------------------------------------------------------------------
current = GetCurrentTool()
newtool = GetSelectedTool()

If current=0 Then      'syncs tool turret
  ActivateSignal(OUTPUT4)      'start turret moving
   While IsActive(INPUT2)=false   'wait for tool index
   Wend
  DeactivateSignal(OUTPUT4)   'reverse tool turret to index
  SetCurrentTool(1)   '<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< is SetCurrentTool(x) the correct format?
  current=1         'this initiallizes the tool changer on startup
End If


If current = newtool Then
   Exit Sub
End If

If newtool>6 Or newtool<1 Then
Message("Next Tool out of range")
    Code "M30"
    End
End If

Code "G53 X-.1"           'position X to safe area
While IsMoving ()
Wend
            '6 position turret - calc next tool count
movedist = (newtool - current) + 1
If movedist <1 Then movedist = movedist + 6
ActivateSignal(OUTPUT4)      'start turret moving

For I=1 To movedist
  While IsActive(INPUT1)=false
  Wend
 
  While IsActive(INPUT1)=true
  Wend
Next I
DeactivateSignal( OUTPUT4 )   'stop and index turret
'  While IsActive(INPUT1) = true
'  Wend
SetCurrentTool(newtool)         '<<<<<<<<<<<<<<<<< is SetCurrentTool(x) the correct format?

 
Mike
Re: New lathe tool turret Help
« Reply #18 on: September 07, 2011, 09:27:13 AM »
you don't have any positional sensors on your toolpost though
Re: New lathe tool turret Help
« Reply #19 on: September 07, 2011, 11:12:58 AM »
No, if you look at the manual above it sends a positional output!!
Thanks
Mike