Hello Guest it is February 27, 2021, 01:15:59 AM

Author Topic: Please Help: 3 MM error on X axis  (Read 2329 times)

0 Members and 1 Guest are viewing this topic.

Please Help: 3 MM error on X axis
« on: August 31, 2011, 07:33:30 PM »
Hello everyone,

I'm having a minor problem that is a major annoyance for me relating to the x axis of my  3 axis servo driven cnc machine.

ive been running it for 4 years.

when cutting concentric circles for example, the z axis cuts at its proper depth, and the y axis cuts at its proper length, but the x axis manifests a 1.5mm error in both directions resulting in an overall 3mm error producing concentric ovals instead of perfect circles.

Ive contacted gecko, but they said it can't be the driver. but if it is, to swap the x with one of the others to test it. that is an option but theres a lot of rewiring to do which id rather avoid if possible.

Anyway, if anyone has any ideas or experience with this type of issue PLEASE let me know

Cheers

Offline Tweakie.CNC

*
  • *
  •  8,659 8,659
  • Super Kitty
    • View Profile
Re: Please Help: 3 MM error on X axis
« Reply #1 on: September 01, 2011, 01:59:23 AM »
Have you checked for loose mechanical parts which are causing backlash ?? - is there any slack in the axis ??
Have you checked that your steps per unit are correct for that axis ??

Just a couple of suggestions.

Tweakie.
KEEP SAFE !

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Please Help: 3 MM error on X axis
« Reply #2 on: September 01, 2011, 02:07:34 AM »
Swapping a Gecko should not involve rewiring, they have plugs, but much more likely its mechanical or steps per unit set wrong as Tweakie says
Hood
Re: Please Help: 3 MM error on X axis
« Reply #3 on: September 01, 2011, 04:51:07 AM »
Ok thanks heaps guys i'll give those suggestions a shot and let you know the outcome.
Re: Please Help: 3 MM error on X axis
« Reply #4 on: September 04, 2011, 03:32:54 AM »
Yep problem sorted. I recently moved the machine out of my bedroom into my workshop and mustn't have tightened the grubscrews properly. I considered every other possible problem except the above possiblity. Next time i'll consult the forum first.
Great Help.
Cheers.

Offline Tweakie.CNC

*
  • *
  •  8,659 8,659
  • Super Kitty
    • View Profile
Re: Please Help: 3 MM error on X axis
« Reply #5 on: September 04, 2011, 03:50:36 AM »
Pleased it was something simple and that you have got it sorted.  ;)

Tweakie.
KEEP SAFE !