Hello Guest it is December 08, 2019, 05:00:45 AM

Author Topic: Kernel speed set to high on z axis and will not save calibration.  (Read 5270 times)

0 Members and 1 Guest are viewing this topic.

My issue is quite madding. I will calibrate z axis and Mach doesn't seem to be saving the calibration and it seems to be increasing the "Steps per".
Steps to reenact issue:
Open mach version R3.043.022 CNC Plasma
Pop window stating "kernel speed set over 25000"
Config - Motor tuning - Z axis - Steps set at 9387.437181 (all other y and x are set around 1900), velocity 159.788019997191, Acceleration 60, g's 0.155411424, Step pulse and dir pulse 0.
Set Z axis to around 2000 and save
Calibration:
settings - Axis calibration(steps per Unit) - Z axis - Start gap of torch head is 2.296"- In the prompt I move Z 1.5"- Z now only moves .298" - Next prompt states "Z axis will be now set at 10067.114 steps per unit" Accept? - yes.
Then when I try to recalibrate Z axis It is sill off by .338 Mach wants to save the steps at 12552.511.
Then if I try to recalibrate Mach wants to increase the steps yet again to 15554.536.

Ran Drive test and it came back System Normal.

Any feed back would be greatly appreciated.
Thank you

Offline alenz

*
  •  137 137
    • View Profile
Re: Kernel speed set to high on z axis and will not save calibration.
« Reply #1 on: August 31, 2011, 03:55:40 PM »
Are you remembering to press the 'Enter' key after each entry?
Re: Kernel speed set to high on z axis and will not save calibration.
« Reply #2 on: September 01, 2011, 11:25:10 AM »
Yes enter was pressed and was that appropriate? How would one get through the prompts with out pressing enter?

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Kernel speed set to high on z axis and will not save calibration.
« Reply #3 on: September 01, 2011, 11:48:14 AM »
You will find that some entries are with an enter press and some are without an enter press SO yes it was an appropriate question to ask.  You have no idea how many times that was the problem.

(;-) TP

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Kernel speed set to high on z axis and will not save calibration.
« Reply #4 on: September 01, 2011, 02:05:03 PM »
Can you attach your xml please.
Hood
Re: Kernel speed set to high on z axis and will not save calibration.
« Reply #5 on: July 08, 2013, 11:06:03 PM »
Did anyone solve this? Mine is doing the same thing. I calibrate and then it sets the new steps/per, but it doesn't even come close when I run a new calibration to check how far it moved. It just keeps coming up short and increasing steps until it maxes out then complains it's too high for 25000 kernel.

What's going on??



Online RICH

*
  • *
  •  7,375 7,375
    • View Profile
Re: Kernel speed set to high on z axis and will not save calibration.
« Reply #6 on: July 09, 2013, 08:03:58 AM »
Make sure you save settings and then go out and back into Mach after the calibration is done.
Double check that the steps per are correct / were changed when you open Mach.

Frankly you should calculate the steps per unit. If the mechanics of the machine is good then when runnning the calibration check you should be spot on. Since the mechanics may not be exact the calibration check can be used to refine
the steps per but use common sense and know why your changing from the calculated number. The Kernel speed can limit the velocity, so lower the velocity setting.

RICH
Re: Kernel speed set to high on z axis and will not save calibration.
« Reply #7 on: July 09, 2013, 09:21:50 AM »
Ok Rich I'll look into that, thanks. I did adjust my X axis drive under the table as it was binding. Now that is fixed it works better of course but I can't get it close to cutting a proper pattern since the dimensions are way off. I knew this would involve a lot of learning but not this much!! LOL..
I'll try and get back here to reply.

Andrew
Re: Kernel speed set to high on z axis and will not save calibration.
« Reply #8 on: July 09, 2013, 09:36:18 AM »
If you're only setting the steps per to 9387, why on earth do you WANT to set the kernel speed above 25K?  There is absolutely no benefit whatsoever to doing so....

Regards,
Ray L.
Regards,
Ray L.
Re: Kernel speed set to high on z axis and will not save calibration.
« Reply #9 on: July 09, 2013, 10:20:37 AM »
I meant to ask as well, what do you do if you calculate the steps per unit and it doesn't work? Then what? Or is that not normally a problem?? I have a 13 TPI threaded rod, a regular 1.8 deg stepper. So at 16 microstepping 3200 steps per revolution. I set my units to MM when I setup Mach3. So 13 tpi is 13 turns for 25.4 MM or 1.95 MM per turn. so.....3200 / 1.95= 1637.79 or 1637. Is that right?? My kernel speed is 25000.