Hello Guest it is May 25, 2019, 12:06:44 PM

Author Topic: ERRATIC BEHAVIOR  (Read 1624 times)

0 Members and 1 Guest are viewing this topic.

ERRATIC BEHAVIOR
« on: August 27, 2011, 07:57:17 PM »
Afternoon folk, a friend and I built a 4 axis machine a few years ago and it has worked pretty well. Naturally when we needed something on a dead line the machine decided to test our patience.
The original computer died. So we replaced that. Then we decided to upgrade the Sound logic break out board, which never gave us a problem, to the new model that would allow spindle speed control through the VFD.
The behavior now is that the z-axis is erratic. If I press the + key it may move + or it may move -. When pressed again it may move + or -. It also makes an unpleasant sound . We have tried to trouble shoot the problem.. We swapped the misbehaving cable from Z to Y, and we switched them at the motor end and the behavior stayed with the third channel (Z) . So we know the motor is good, and the cable is good,. I've swapped the leads from the breakout board, z=y &y=z, to the mil-spec plugs that the cables connect to and the problem stayed with the 3rd (Z) channel. I've gone over the wiring with an ohm meter and it all seems good. I swapped the gecko for a new one. I swapped the computer to a known good one. Swapped the breakout board to the old one that always worked fine. Running out of things to blame I went from Parallel Port control to Smooth stepper USB control and the behavior is still the same. Also when I  watch the dir lights on the breakout board the light comes on when the + key is pressed and off when the - key is pressed but the axis will move erratically one way or the other. Seems to me that I have one way or another eliminated everything BUT it still doesn't work.  I searched the site here and found a similar problem and the suggestion was that one stepper wire was bad but as I say all the cables and the wiring seem to be fine. I think I will up-grade Mach 3 but just out of desperation.

Any thoughts?
thanks
Mike
Re: ERRATIC BEHAVIOR
« Reply #1 on: August 27, 2011, 08:29:33 PM »
nevermind... As was said by the brain trust here before ...it has to be wiring. And it was ... bad milspec connector.
But it works now
thanks
Mike