Hello Guest it is October 19, 2019, 09:41:34 PM

Author Topic: Spindle turning off during cycle  (Read 1814 times)

0 Members and 1 Guest are viewing this topic.

Spindle turning off during cycle
« on: August 01, 2011, 07:14:04 PM »
I've been running Mach 3 for about two years now, but recently on my cnc router, the spindle will stop running in the middle of a program for some unknown reason.  I can restart spindle by first clicking to turn spindle off in Mach and then by clicking again to restart.  Only happens every once in a while, maybe twice a day in 8 hours of running, but afraid to leave machine alone for fear if spindle stops will damage machine, tool bit, and part I'm cutting.

Any ideas would be greatly appreciated.

Justin

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: Spindle turning off during cycle
« Reply #1 on: August 01, 2011, 07:38:24 PM »
That sounds like a spindle control problem. Possibly a bad port pin, Bad BOB(opto), bad wire, connection or bad holding relay. To test to see IF it is mach3 doing it when it happens you need to check the port pin that control the spindle "on" and see IF it is still active. If it is then it is not mach3 or the PC. Check the spindle control downline of the PC.

Some BOBs have leds that show the port as active that would be an easy check. When it fails check the LEDs before you restart the spindle

Hope that helps, (;-) TP
Re: Spindle turning off during cycle
« Reply #2 on: August 01, 2011, 08:47:12 PM »
Thanks for the post, I'll check that if it happens again. 

Justin