Hello Guest it is November 15, 2019, 04:53:11 AM

Author Topic: Jogging while config screen up  (Read 1385 times)

0 Members and 1 Guest are viewing this topic.

Jogging while config screen up
« on: July 28, 2011, 07:59:56 AM »
Home built router, smoothstepper interface to 2 breakout boards. Latest mach lockdown, latest SS driver and plugin.

I noticed while tuning my A Axis that when I bring up the motor tuning dialog (or any configuration dialog) I can jog any axis at full speed once. I am using the XBox controller but I can also duplicate this with a wired MPG. So, I reference all axes, then go to the motor tuning dialog to input accelleration and velocity and accidentally touched the X axis joystick and the X axis moved, pressing a second time and no motion, tried all other axes and they all move just once, activating a second time does nothing. The MPG is wired to port3 on the SmoothStepper

I don't know if this is the way it should function or whether it is a problem with Mach or the Smoothstepper but I gave me a bit of a fright nonetheless. I've reported it to Lee (Xbox controller plugin) but I'm more convinced this might be a problem with Mach ot the SS (if it is indeed a problem). Could someone who knows Mach and the SS better than me please try and duplicate this as I'm not sure this is supposed to happen and it could be dangerous.

Regards, Jeff.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Jogging while config screen up
« Reply #1 on: July 28, 2011, 08:07:07 AM »
Just tried it and indeed it will jog once via MG. Suspect it may be a SmoothStepper thing but as I dont have a machine with a parallel port I am unable to test without the SmoothStepper, hopefully someone else will test.
Hood