Hello Guest it is May 25, 2019, 05:35:01 AM

Author Topic: Jog Hot keys don't work.  (Read 8019 times)

0 Members and 1 Guest are viewing this topic.

Jog Hot keys don't work.
« on: July 27, 2011, 11:45:10 AM »

I just installed Mach3 on a Dell Inspiron 560s running 32-bit windows 7 and a Rosewill 2 port Parallel Universal PCI card, Model RC-304.

The installation seemed to go fine and I started doing a dry run. The jog “fly-out” screen  would not change the values on the axis DROs when I clicked on it and when I would enter in in the MDI (ie G00 X1.6 Y2.3 ) the axis DROs would not change. I reread the manual about about  the driver test program and realized I was running the Rosewill driver. I went to the device manager and disabled the mach3 driver. The axis DROs now change when I enter values in MDI and they also change when I click on the buttons on the Jog “fly-out” screen. The Jog hot keys do not work. (I set them to the correct ones (From 999) in the key configuration.)

I am (obviously) new to the CNC world and want to make sure everything is working as the manual indicates before plugging in my machine.

Offline ger21

*
  • *
  •  6,233 6,233
    • View Profile
    • The CNC Woodworker
Re: Jog Hot keys don't work.
« Reply #1 on: July 27, 2011, 12:00:31 PM »
The mach3 driver must be running. The Rosewill driver just let's Mach3 see the parallel port, but the Mach3 driver controls it. There really two completely differernt things.
Sounds like you don't have something setup properly in mach3. make sure all the motors are enabled.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Jog Hot keys don't work.
« Reply #2 on: July 27, 2011, 12:51:27 PM »
It worked  ;D.

I clicked the check next to the axis in the "motor output". I am doing the "dry run" and it didn't say anything about enabling the motors.

Thanks.
« Last Edit: July 27, 2011, 12:56:18 PM by sawcnc »
Re: Jog Hot keys don't work.
« Reply #3 on: July 27, 2011, 01:12:07 PM »
Me too!!!!


I just loaded MACH3 per the manual on a Pentium 4 266 that was totally rebuilt with XP-Pro  and see the same thing. MACH and MS office are the only major software on the machine.   It passes the speed/timint tests with an excellent rating.   

Jog interface buttons don't work and I get no DRO response from G code entered from the keyboard in the MDI window like the manual suggests.

I've read and re-read the manual with no luck, but it wouldnt be the first time I missed something that should have poked my eye out.... 

Offline Hood

*
  •  25,817 25,817
  • Carnoustie, Scotland
    • View Profile
Re: Jog Hot keys don't work.
« Reply #4 on: July 27, 2011, 02:16:15 PM »
Can you attach your xml please.
Hood
Re: Jog Hot keys don't work.
« Reply #5 on: July 27, 2011, 03:22:42 PM »
Attached is my XML.

I am a total newbie so all of this is like swimming in jello for me.  I have a blacktoe almost fully assembled, but am holding off on the motors so I can test the electronics with MACH3.  I think I have followed the directions in the installation document to the letter so I am totally stuck on this.

Thanks in advance for any help you can give me on this.

Rye

Offline Hood

*
  •  25,817 25,817
  • Carnoustie, Scotland
    • View Profile
Re: Jog Hot keys don't work.
« Reply #6 on: July 27, 2011, 03:56:42 PM »
If you go to Config menu then Ports and Pins then Motor Outputs you can then enable each axis you want to use. No need to set port and pin numbers at this stage if you dont have motors set up.
You will also have to enable the Jog contro (Jog On/Off)l, its in the middle section of the main screen

Hood
Re: Jog Hot keys don't work. (Got it)
« Reply #7 on: July 27, 2011, 03:56:59 PM »
GOT IT!

I went to the port config and turned on the X and Y axis and now it worked like a champ.

I guess that's what the earlier comment was about, but I couldn't translate that fix to the port configuration. 

It might make sense to add an item to the configuration manual on this as it's always discouraging to get stumped after only the first ten pages.....

I have a little bald spot from scratching my head all morning, but it feels good to solve the problem.  Time for a beer!
Re: Jog Hot keys don't work.
« Reply #8 on: July 27, 2011, 04:04:17 PM »
Thanks Hood.  It looks like we cross posted within a couple of seconds of each other. 

It is so encouraging to know that there are kind people like you out there who are willing to help newbies like myself when they blunder into a corner and cant get out of it. 

Offline Hood

*
  •  25,817 25,817
  • Carnoustie, Scotland
    • View Profile
Re: Jog Hot keys don't work.
« Reply #9 on: July 27, 2011, 05:50:31 PM »
Good you got it, thats the main thing. Its a steep learning curve but you will soon find your way around :)
Hood