Hello Guest it is July 05, 2020, 11:44:38 PM

Author Topic: Slave not synchronized  (Read 4536 times)

0 Members and 1 Guest are viewing this topic.

Slave not synchronized
« on: July 24, 2011, 04:09:24 PM »
Hello everyone

I have build a gantry style router, and i'm using the X- and A-stepper to drive the gantry. The X-stepper is master and the A is slave. Some of the time the steppers move perfectly in sync, but then suddenly one of the steppers loses steps, and drives the gantry out of square. I'm using shielded cabels, and have connected the sheild-wire to the stepper housing at one end, and to the controlbox at the other end.

In "motor tuning" i have tried to set the "step pulse" to 4, which seems to help a little, but it is not good. I will be very greatful to anyone with some advice, on how i get the master and slave to drive in sync.

Regards
Jens from Denmark

Offline Tweakie.CNC

*
  • *
  •  8,345 8,345
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Slave not synchronized
« Reply #1 on: July 25, 2011, 02:32:40 AM »
Hi Jens,

Welcome to the forum.

Ideally all cable shields should only be connected to ground at the controller end. This avoids 'earth loops' which are notorious at collecting electrical noise and spoiling the step pulse train.

Try disconnecting your shields at the motor ends and also increasing the "Inputs Signal Debouncing/Noise rejection" setting in Config / General Config.

Tweakie.
KEEP SAFE !
Re: Slave not synchronized
« Reply #2 on: August 09, 2011, 04:21:40 AM »
Hi Tweakie

Thanks for your reply! I have now disconneted the grounds form the stepper housings, but unfortunately I'm still loosing steps. I forgot to try setting the Input Signal Debouncing, but shouldl it make a difference, when i haven't connected any limit switchs yet? -I'll try setting the debouncing today...

I discovered a few other things that mayby can help solve the problem. Until now I haven't hat a grounded cabel for my computers power supply. Yesterday I changed it to a grounded one, and I found, that if I put it into the same power outlet as the controller, the steppers gets a lot more noisy.

If I use different power outlets for the controller and the computer, the steppers  noise level stays normal. -by the way, is it normal that the steppers makes at buzzing sound, when they are not moving?

Another thing I found was, that if i use the Mach3 auto axis calibration function "set steps per unit", the stepper will only move, if I've just moved it in the same direction, as the calibration function is going to move the stepper.  If I just moved the stepper in the opposite direction, the callibration function will not move the stepper. Instead the stepper stalls, like when you set the velosity way to high.

Has anyone got an idea what could be the problem?

Thanks in forhand
Jens

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Slave not synchronized
« Reply #3 on: August 09, 2011, 04:27:54 AM »
If setting a wider pulse helped then it could well be needing even wider yet, some drives require a very wide pulse so if your motor tuning requires 25KHz  or less then try Sherline mode (ports and pins main page) to see if that helps.
Hood

Offline Tweakie.CNC

*
  • *
  •  8,345 8,345
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Slave not synchronized
« Reply #4 on: August 09, 2011, 04:50:18 AM »
Hi Jens,

The grounding / earthing issue is quite complicated but everything metal that you can touch (which comprises equipment connected to the incoming AC mains supply) must be connected to earth. Sometimes the incoming mains supply comes with a good earth, sometimes an earth stake is fitted close to the mains inlet.
Earth and Ground should be treated as two separate circuits when connecting up your CNC.
You must try to avoid Earth loops which could explain this
Quote
I found, that if I put it into the same power outlet as the controller, the steppers gets a lot more noisy.
The same applies to Ground loops which is why GND connections are only made at one end of shielded cables.
It may save you some time if you have a local friend who is an electronics expert who can look at your system and help you eliminate any GND or Earth loops that you may have.

My steppers make a high pitched sound when stationary if that's any help.

Tweakie.
KEEP SAFE !

Offline ERP

*
  •  35 35
    • View Profile
Re: Slave not synchronized
« Reply #5 on: August 09, 2011, 12:57:49 PM »
It does sound like a noise issue, especially if it's bette with the computer in a different socket.

Having said that if the motor is stalling on a direction change I'd aslo try turning down you acceleration, and disabling backlash compensation. It's possible you have the backlash compensation tuned to too high a % of the rapid rate, causing the motor to stall on direction changes.
Re: Slave not synchronized
« Reply #6 on: August 12, 2011, 01:00:14 PM »
Hi every one

Sorry it took som time for me to reply! Hood nailed it ;D Turning on Sherline mode seem to have solved the problem, at least I can't see that the steppers are missing steps anymore :) A lot of thanks to you all, I'm a happy man, -it really means a lot to get help!!

Jens