Hello Guest it is July 05, 2020, 04:45:53 PM

Author Topic: Code will not run  (Read 1681 times)

0 Members and 1 Guest are viewing this topic.

Code will not run
« on: July 21, 2011, 11:14:42 AM »


Hi,

   I have generated the following code in Bobcad v23 and it will not run in Mach3 offline. I want to run offline to see the results before going to the machine. Could someone take a look and see what would be the cause of the code not running?

Thanks,

          Ernie

(BEGIN PREDATOR NC HEADER)
(MACH_FILE=3AXVMILL.MCH)
(MTOOL T1 S1 D.25 H5. DIAM_OFFSET 1 = .125)
(SBOX X0. Y0. Z-1. L8. W8. H0.)
(END PREDATOR NC HEADER)

%
O100
(PROGRAM NUMBER)
(PROGRAM NAME - GL-5210-6-005TEST.TXT)
(POST -  MACH 3 MILL NO ATC)
(DATE - THU. 07/21/2011)
(TIME - 11:01AM)

N01 G20 G40 G49 G54 G80 G90 G91.1
N02 G53 Z0.

(JOB 1  CENTER HOLE  RANDOM POINT PATTERN)
(FEATURE CENTER DRILL)

N03 T1
N04 S504 M03
N05 G00 G90 G54 X4. Y4.
N06 G43 H1 Z.1 M08
N07 G81 G98 X4. Y4. Z-.1 R.1 F1.0084
N08 X3.1161 Y4.8839
N09 X2.5416 Y5.4584
N10 X1.6184 Y5.375
N11 X1.9375 Y4.
N12 X2.75
N13 X3.1161 Y3.1161
N14 X2.5416 Y2.5416
N15 X1.6184 Y2.625
N16 X1. Y.5
N17 X4.
N18 Y1.25
N19 Y1.9375
N20 Y2.75
N21 X4.8839 Y3.1161
N22 X5.4584 Y2.5416
N23 X6.3816 Y2.625
N24 X6.0625 Y4.
N25 X5.25
N26 X4.8839 Y4.8839
N27 X5.4584 Y5.4584
N28 X6.3816 Y5.375
N29 X7. Y7.5
N30 X4.
N31 Y6.75
N32 Y6.0625
N33 Y5.25
N34 X1. Y7.5

Offline Tweakie.CNC

*
  • *
  •  8,345 8,345
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Code will not run
« Reply #1 on: July 21, 2011, 11:32:34 AM »
Seems to run OK here Ernie.

What doesn't happen with your setup.

Tweakie.
KEEP SAFE !
Re: Code will not run
« Reply #2 on: July 21, 2011, 11:50:20 AM »
It runs to line N01 and stops. It will not run from there. There is a message next to the clear button that reads " Feature Center Drill ". The only thing that I have noticed is that my spindle speed is set to 25000 RPM's and I cannot change it.

Thanks,

           Ernie

Offline Tweakie.CNC

*
  • *
  •  8,345 8,345
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Code will not run
« Reply #3 on: July 21, 2011, 12:11:27 PM »
Ernie,

Just tried it again and it is OK.
Perhaps reloading Mach may cure the problem you have with your spindle speed DRO.

Tweakie.
KEEP SAFE !

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Code will not run
« Reply #4 on: July 21, 2011, 01:17:07 PM »
Do you have the axis enabled?
Hood