Hello Guest it is June 17, 2019, 09:38:56 AM

Author Topic: machine not backing off homing switch  (Read 3161 times)

0 Members and 1 Guest are viewing this topic.

machine not backing off homing switch
« on: June 21, 2011, 01:55:22 AM »
Hi everyone,
I know I should make an intro post first but it's late at night and I am fighting with the homing of the machine. So just real quick for now:
After working with a Multicam3000 3 axis router with added knife assembly and i-cut system for a few years at work I just finished building my first own machine. Its based on the solsylva plans and has a G540 drive from Gecko and 380oz steppers.

Now for my problem: When trying to ref all home the z axis moves up (which it is supposed to) until it hits the home switch and then the machine shuts off and never even tries to back off the switch. Message: External Estop requested.
I got all 3 axis switches in series on pin 10 and all switches work, according to the diagnostics screen and when I jog into them. In ports and pins all are active and set to active high (red x at active low column). In home/soft limits all are auto zero and x and y are home neg.

I am pretty sure I forgot a setting somewhere but I can't figure it out. I need some advise please

Thanks
Lukas

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: machine not backing off homing switch
« Reply #1 on: June 21, 2011, 05:10:43 AM »
Sounds like your switches are bouncing, ie the contacts open then shut then open because the switch action is not positive. Try setting an Debounce Interval to 2000 and see if it helps, you will find that setting from Config menu then General Config and its top right. If that helps then really it shows your switches are a problem and possibly need replaced with better quality ones.

One other thing that may be causing the problem is Pin 10 is the default for E-Stop, if it is still set up as pin 10 then that will do exactly as you are seeing.
Hood
Re: machine not backing off homing switch
« Reply #2 on: June 21, 2011, 09:20:45 AM »
I read about the debounce in a different post and tried it but no result. I do however have the home and estops on pin 10. The wiring is setup as in the gecko g540 manual. I am not at the machine right now but would it fix it if I set the home switches to a different pin than the estop, for example 11, I would wire it to the second input on the g540. Are there any other settings for the machine to automatically backoff when hitting a switch while homing or is that the default?
Lukas

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: machine not backing off homing switch
« Reply #3 on: June 21, 2011, 09:25:13 AM »
The way Mach homes is it seeks the switch, triggers it and backs off until the signal goes away and then that is set as home. It is the way it is and no further setup required.

Not familiar with the G540 setup so maybe they are doing something clever with the inputs but cant see how.
Hood
Re: machine not backing off homing switch
« Reply #4 on: June 21, 2011, 10:38:07 AM »
I tried deactivating the estop in the setup so it doesn't interfere with the home switches which are on the same pin 10 but it still does not back up. I will try to wire it different tonight and see I that helps.
This is the wiring diagram I used (page 6) and the connectors on the drive (page5) http://www.geckodrive.com/images/fck_uploads/G540%20REV4%20MANUAL.pdf

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: machine not backing off homing switch
« Reply #5 on: June 21, 2011, 10:40:13 AM »
You can not deactivate the E-Stop as such but you could set it up to a pin not being used by anything else and changing the active state to suit.
Hood

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: machine not backing off homing switch
« Reply #6 on: June 21, 2011, 10:45:09 AM »
Just looked at the wiring and seems they have the E-Stop to pin 15 of the parallel port or at least looks that way from a quick glance.
Hood
Re: machine not backing off homing switch
« Reply #7 on: June 21, 2011, 10:52:55 AM »
I will try to configure/wire it so the estop and the home switches don't overlap. I will report back if it works. I appreciate your fast responses, thank you!
Re: machine not backing off homing switch
« Reply #8 on: June 22, 2011, 01:26:37 AM »
I tried to set the estop on pin 15 but the machine would not come out of fault mode so I set it back to 10. Since I have all switches in series I only need one input anyway so I rewired it to pin 11 which is the second connector on the breakout bar from the left (I don't have the manual available while writing this so I can't look up what number the input has, should be input 2). This finally let me home the machine. However, next jog I ran into the switch and the limit did not kick in. I went back to the input config and activated x--,y-- and z++ limits all on pin 11. Now the machine homes, stops when it hits a limit switch and the soft limits are setup as well. I guess I am ready to make my first testcut tomorrow :-)
Lukas