Hello Guest it is June 02, 2023, 09:08:25 PM

Author Topic: Z plunges too far and ruins jobs; Mach misses lines; wailing/gnashing of teeth  (Read 3144 times)

0 Members and 1 Guest are viewing this topic.

I've had a persistent, if intermittent problem with Mach3: My Z axis tends to get carried away and plunge too far (or not retract fully). The results are as dire as you'd expect - Ruined work, lost time and broken tools. I've got a hole in the top of my vice with an expensive 8mm cutter snapped of in it from the last episode. This isn't something I can reproduce as it only happens infrequently. Any clues on this? I'm getting a bit paranoid about it since I've got some big milling jobs to get through shortly and I don't want them going wrong.

The other point that may be related is that Mach occasionally seems to skip instructions or stop short of a finishing point. This is usually when approaching the end o a cut with a G41 offset on - instead of continuing to the end of a a cut it stops significantly short before lifting the spindle. The only way i can correct this is by programming the same line twice.

Again, any clues on this? This BS is giving me ulcers just thinking about it  ???

Offline docltf

  •  354 354
    • View Profile
this might not help you but it is something to think about.last month my machine started to flip out doing weird stuff when running mach.
the cause was the hard drive was starting to crash.it started doing the occasional then got worse.made a image of the drive and transferred it
to a new drive.have you noticed your computer slow booting or slow loading?


Offline RICH

  • *
  •  7,428 7,428
    • View Profile
Is the motor getting hot? Is it skipping and you can't tell?
Intermittent problems are a pain since you can't duplicate  to find  the cuse .......which can be a number of things.


Offline Hood

  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Does the toolpath view follow the axis movement when it goes walk about?

Sounds more like the Z losing steps to me, presume its a stepper system? Often if you have the Z tuned at the edge and the quill heats up a bit the axis will lose steps on the up stroke and thus move lower than it should. Have you tried backing off on the Vel and Accel for the Z?

Could be that, I detuned the motors a little and made a point of pumping the oiler and exercising the slides first thing and it hasn't happened recently. The toolpath showed the correct position along with the DROs. The other embuggerance is an occasional runaway of the X and Y axes - the DROs update slowly, about once every two seconds, and simply show rapidly rising (or falling) values carrying the tool along an uncommanded 45 degree path as fast as it will go. The toolpath shows it going, but makes no effort to stop it. Nedless to say, not good. I solved this once by leaving G41 on between subroutine executions instead of cancelling and reapplying it each time, but it's come back in a different program. Do I need to cancel G41 before using G0 or is this something else? It's a horrendous error and not one I want to repeat.

I don't think it's a HDD failure as the computer is nearly new and fairly decent in other respects. There have been no bothers such as slow booting or hanging.