Hello Guest it is June 17, 2019, 01:32:10 PM

Author Topic: Spindle Problem and 2nd Parallel port issues  (Read 2182 times)

0 Members and 1 Guest are viewing this topic.

Spindle Problem and 2nd Parallel port issues
« on: June 14, 2011, 10:45:28 AM »
I have 2 separate issues that are driving me insane....

1. When I start the spindle in MDI so that I can jog the machine with my MPG to cut manually, the spindle just randomly stops. If the Machine is running with a g-code file it has no problems. I am using the CNC4PC 6axis MPG.

2. When I first boot up the pc that runs the mill Mach does not enable pins 1-9 for input even though the box is checked. I have to open pots/pins, uncheck the box, hit ok, then open ports/pins and re-enable it and then they will work.

Not sure what is causing all of this. Any ideas?

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: Spindle Problem and 2nd Parallel port issues
« Reply #1 on: June 14, 2011, 10:52:31 AM »
Can you attach your xml please.
Hood
Re: Spindle Problem and 2nd Parallel port issues
« Reply #2 on: June 14, 2011, 11:25:48 AM »
Sure can...

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: Spindle Problem and 2nd Parallel port issues
« Reply #3 on: June 14, 2011, 02:02:16 PM »
Dont see anything wrong with the xml.
Does the spindle do the same when jogging via keyboard? If it does then disable the Brain for the MPG (if ther is one) and see if it still does it.
Hood
Re: Spindle Problem and 2nd Parallel port issues
« Reply #4 on: June 15, 2011, 03:48:58 PM »
Turning the brain off does stop the issue but then I can not use my MPG. I can contact Art from CNC4PC about that but have any idea as to the 2nd parallel port input pins issue?

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: Spindle Problem and 2nd Parallel port issues
« Reply #5 on: June 15, 2011, 04:32:40 PM »
Only thing I can think of is the port may be set to auto mode or possibly your xml is set as read only. If the latter is the case then Mach writes to the xml when you close Mach so it will try and write but if its set read only then it wont be able to, so next time you start Mach its back to the way it was.

You could try the save config setting in Mach, think its under  Config menu. Change pins 2-9 as inputs and then save config and then look again to see if its still set, then try exiting Mach and  restarting and see if its still set.
Hood