Hello Guest it is October 18, 2019, 01:29:16 PM

Author Topic: Size Help  (Read 4151 times)

0 Members and 1 Guest are viewing this topic.

Size Help
« on: June 12, 2011, 01:28:58 PM »
I am running Dolphin CAM V10 with Mach 3. I just got it along with a Sieg KX1.

The problem is z travel seems fine, but x-y seems tiny.

I believe it is all in metric, I've checked the settings in Mach 3 controller and in the Dolphin CAM. Every time I start CAM a window pops up with options including inch or metric. I always choose Metric, All my read outs are in metric in the controller. In CAM under set up>machine type> mill> it is set to metric.

In the Controller Mach 3, under General Logic Config The G20-G21 box is blank (unchecked) for _ LOCK DRO's to Setup Units. Should this be checked?

One funny thing is the diameter of the cutter changes once the program is loaded. I set the tool info in mach 3 to 6.37mm, and I also set the same info when writing the CAM program and it changes to 161.798mm??? I am using a template program to cut a simple rectangle pocket.

The only other thing I can think of that might be funny is that I have written the program in CAM, Post Processed it from Dolphin CAM so it is now a .ppr file, then I load it from the "My Documents" folder.

I've included pics of Regen and Tool Setting changes before and after the program is loaded. Am I right that it is cutting, but just really small?

Any help is truly appreciated.

Thanks,

Mark Stehr

Offline JimG

*
  •  13 13
    • View Profile
Re: Size Help
« Reply #1 on: June 13, 2011, 08:13:31 AM »
I am running Dolphin CAM V10 with Mach 3. I just got it along with a Sieg KX1.

The problem is z travel seems fine, but x-y seems tiny.

I believe it is all in metric, I've checked the settings in Mach 3 controller and in the Dolphin CAM. Every time I start CAM a window pops up with options including inch or metric. I always choose Metric, All my read outs are in metric in the controller. In CAM under set up>machine type> mill> it is set to metric.

In the Controller Mach 3, under General Logic Config The G20-G21 box is blank (unchecked) for _ LOCK DRO's to Setup Units. Should this be checked?

One funny thing is the diameter of the cutter changes once the program is loaded. I set the tool info in mach 3 to 6.37mm, and I also set the same info when writing the CAM program and it changes to 161.798mm??? I am using a template program to cut a simple rectangle pocket.

The only other thing I can think of that might be funny is that I have written the program in CAM, Post Processed it from Dolphin CAM so it is now a .ppr file, then I load it from the "My Documents" folder.

I've included pics of Regen and Tool Setting changes before and after the program is loaded. Am I right that it is cutting, but just really small?


Mark,

I think your problem with the tool size is caused by Mach starting in Imperial.  When you load your Gcode which you generated in Metric,  there will be a G21 - probably in the first line - and that switches Mach to Metric mode and multiplies all dimensions by 25.4,  hence your 6.37 tool diameter changing to 161.798.   I had similar problems to this when I started with my KX1 and had several peculiarities like yours working in metric.   I saw that Mach always seemed to start in Imperial so I added a G21 entry to the initialisation string in General Config and now everything seems to work as I intended.

Jim.
Re: Size Help
« Reply #2 on: June 13, 2011, 09:10:50 AM »
Awesome thanks Jim!

I'll give that a try. Thanks for the help!

Mark