Hello Guest it is August 18, 2019, 07:52:05 AM

Author Topic: This might be a quick fix - Fast Jog  (Read 6466 times)

0 Members and 1 Guest are viewing this topic.

This might be a quick fix - Fast Jog
« on: June 07, 2011, 09:45:36 PM »
In short I'm a new user to mach 3 I've bought the AJAX cnc kit got all the wires hooked up tuned my motors best I knew (Took a high end set of calipers and asked it to move 5 inches then I put in the real values from the calipers) I can even slow jog the motors around quite nicely now.

My question is my Fast jog refuses to work I can slow jog all day but no love on the Fast, I've tried this now on two computers both are core duo's 2.0 or faster only thing in common is the graphics are built in plenty of ram in both (Formatted both and reinstalled everything to make sure there were no problems)

I even see on the jog flyout that the little yelllow light is turning on.

So here's what I'm doing: I press the directional keys on the keyboard and it slow jogs fine. I press the Shift key I see the light turn on and press the directional keys again expecting it to move FASTER (this is the way you do it right??)

Offline BR549

*
  •  6,886 6,886
    • View Profile
Re: This might be a quick fix - Fast Jog
« Reply #1 on: June 07, 2011, 10:01:27 PM »
SET the slow jog percentage to 50%.

jog with keys motion is 50% of full rapid
Hold downSHIFT and press keys motion is 100% rapid speed
release SHIFT key and it goes back to slow jog when you press the key again

(;-) TP
Re: This might be a quick fix - Fast Jog
« Reply #2 on: June 07, 2011, 10:09:40 PM »
So I try that but here's the stick. When I Hold Shift down and depress the directional keys reguardless if I have it set to 50% or 100% it does Not move. I release the shift key slow jog is back Depress the shift key and try to move nothing at all. (The light for fast jog is on)


Offline BR549

*
  •  6,886 6,886
    • View Profile
Re: This might be a quick fix - Fast Jog
« Reply #3 on: June 07, 2011, 10:44:22 PM »
SOunds like that might be a problem in the AJAX plugin side as the feature works here OK and you see the FAST jog light come on.

Check with AJAX for support problems

(;-) TP
Re: This might be a quick fix - Fast Jog
« Reply #4 on: June 07, 2011, 11:11:58 PM »
thanks I'll go bug Ajax awhile and see if they say it's mach's problem lol

Offline BR549

*
  •  6,886 6,886
    • View Profile
Re: This might be a quick fix - Fast Jog
« Reply #5 on: June 07, 2011, 11:27:20 PM »
It may be they don't support that function in their plugin. ???

(;-) TP
Re: This might be a quick fix - Fast Jog
« Reply #6 on: June 24, 2011, 11:46:34 AM »
I have a similar problem. I set the auto-override button so that I would be able to jog off of the limit switches after homing, but when the auto-override is in on, the fast jog will not work; only slow jog. If I turn off the auto-override, then the fast jog works again, so I have to go through the whole process of homing, moving off the limit switches, then turning off the auto-override. How does the auto-override cause this problem?

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: This might be a quick fix - Fast Jog
« Reply #7 on: June 24, 2011, 11:55:39 AM »
First thing is you should not have to jog off the switches when homing as the switches should be closed after the homing has complete. If you are having issues with that then you need to sort that first.

Issue with slow jog is because when you have auto limit override set the jog speed is reduced when you jog off a switch, this is because the switches get overridden and it is in case you accidentally jog the wrong way. You can however just jog slightly then stop jogging then jog again and full speed will be restored.
Hood
Re: This might be a quick fix - Fast Jog
« Reply #8 on: June 24, 2011, 01:21:40 PM »
Actually, I neglected to mention that I don't actually have to jog off the limit switches. I can enter a command to move the axes off, too, but even after they are off the switches, the fast jog will still not work. I can try several times, but nothing changes until I go back into the input settings and disable the auto-override. There is also another puzzling aspect of jogging. When I originally installed the system, the jog mode would only activate when I used the tab key to show the virtual pendant. Now, for some reason, jog works anytime, regardless of the pendant. I don't know what I did to cause that to change.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: This might be a quick fix - Fast Jog
« Reply #9 on: June 24, 2011, 01:26:11 PM »
Can you attach your xml please and I will have a look.
Hood