Hello Guest it is November 29, 2021, 07:26:40 AM

Author Topic: Steppers stalling at a certain speed  (Read 2480 times)

0 Members and 1 Guest are viewing this topic.

Steppers stalling at a certain speed
« on: June 07, 2011, 06:28:04 PM »
Hi - I would appreciate some advice. The x and y axes steppers on My Boxford 190 VMC whine and jerk and stall, but only at a feed rate of around 800 mm per min (say 750 to 850) - all other feed rates have no problem and run smoothly. The motors and drivers are originals with a breakout board added. Can anyone advise where I should start to diagnose the issue? Cheers and thanks in advance. TheMule

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: Steppers stalling at a certain speed
« Reply #1 on: June 07, 2011, 07:13:44 PM »
Are you meaning  just at or near that feedrate or anything above it?

RICH
Re: Steppers stalling at a certain speed
« Reply #2 on: June 08, 2011, 03:11:07 AM »
Fine below and above - up to 1500 which is the limit of the machine. It's just that narrow range that is the problem.

Offline Tweakie.CNC

*
  • *
  •  8,863 8,863
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Steppers stalling at a certain speed
« Reply #3 on: June 08, 2011, 03:25:39 AM »
If it's 'mid-band resonance' there are 'easy to make' mechanical devices that can be fitted to the steppers if there is room. There are also electronic solutions as built into the Gecko drives etc.
There is much information on this subject both here and on the Zone if you do a search.

Tweakie.
KEEP SAFE !
Re: Steppers stalling at a certain speed
« Reply #4 on: June 09, 2011, 02:40:24 AM »
Ah - that makes sense and exactly matches the symptoms I am seeing. Now I know that resonance is the issue I can progress. Many thanks