Hello Guest it is October 16, 2019, 04:08:40 AM

Author Topic: Problem with Software/Settings ????  (Read 4025 times)

0 Members and 1 Guest are viewing this topic.

Offline kcib

*
  •  78 78
    • View Profile
Problem with Software/Settings ????
« on: June 04, 2011, 02:37:18 PM »
I have just made a router/plasma cutting machine and have today been cutting air with the router to ensure all axis are working correctly , next step after that was to put a pencil in the spindle of router so that the roadrunner file would be drawn on table surface it came out perfectly apart from the fact that it was drawn upside down and back to front , I have tried various things to correct this problem without any luck does anybody have any ideas as to why it would machine a part upside down and back to front ????
Alan

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Problem with Software/Settings ????
« Reply #1 on: June 04, 2011, 03:54:57 PM »
You have your X and Y axis moving backwards. Try going to Config >Homing Limits and check the "Reverse" box for both.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline kcib

*
  •  78 78
    • View Profile
Re: Problem with Software/Settings ????
« Reply #2 on: June 04, 2011, 03:56:31 PM »
Have already tried the obvious things to try and counteract the problem without any luck
Thanks
Alan

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Problem with Software/Settings ????
« Reply #3 on: June 04, 2011, 04:00:11 PM »
If it's backwards and upside down, reversing the axis HAS to fix it.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline kcib

*
  •  78 78
    • View Profile
Re: Problem with Software/Settings ????
« Reply #4 on: June 04, 2011, 04:19:38 PM »
Have just reversed the "X" and "Y" axis as you said but then the axis DRO's are reading + when it should be minus and vice versa which then makes the homing position in the opposite corner , far left instead on near left , what else can i try ??
Alan
Re: Problem with Software/Settings ????
« Reply #5 on: June 04, 2011, 04:46:40 PM »
Would be nice if we could see your setup in action or just pictures.

Easier to figure it out.


Jeff

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Problem with Software/Settings ????
« Reply #6 on: June 04, 2011, 06:17:56 PM »
Homing position has nothing to do with the direction of the axis. You need to set up your home switches to accommodate the machine moving in the correct directions.

As for the DRO's, they'll read exactly what the g-code tells them too. If you want to run parts in negative coordinates, they need to be programmed that way. The Roadrunner is programmed in positive coordinates, so that tells me that your machine was running backwards.

If you have your home position in the back right, you can't have X+ go left, and Y+ move towards you.

You can use home offsets to set your home switches to be the max positive coordinates, which would make your 0,0 at the lower left.

As Jeff says, a pic or drawing of the machine layout would be a big help.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline kcib

*
  •  78 78
    • View Profile
Re: Problem with Software/Settings ????
« Reply #7 on: June 04, 2011, 07:56:17 PM »
Home switches are set to the max positive and 0,0 is at the lower left as it should be , cannot show any pics as I do not have a camera to hand but the machine is just a standard table with a gantry nothing fancy , I have now run a few of the sample files , roadrunner , skull and scorpion and I get the same result each time , I run the same files on my mill and they work fine , and all the settings on the router are the same apart from a couple of settings which would make no difference to what is happening.

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: Problem with Software/Settings ????
« Reply #8 on: June 04, 2011, 09:00:38 PM »
Axis travel on a knee type mill and a gantry mill are backwards to each other.

(;-) TP

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Problem with Software/Settings ????
« Reply #9 on: June 04, 2011, 09:26:00 PM »
Quote
Home switches are set to the max positive and 0,0 is at the lower left as it should be

Then why are you expecting coordinates to be negative??? They can't be if it's setup as you describe.
Quote
Have just reversed the "X" and "Y" axis as you said but then the axis DRO's are reading + when it should be minus
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html