Hello Guest it is December 16, 2019, 07:41:03 AM

Author Topic: New setup...and having a problem.  (Read 1922 times)

0 Members and 1 Guest are viewing this topic.

New setup...and having a problem.
« on: May 30, 2011, 04:21:51 PM »
I decided to try something new.  I've been using the Gecko G540 drive with no problems, but decided to go to larger motors than what the G540 could handle.  Here is the new setup...

- 65V unregulated power supply
- PMDX-122 breakout board
- Gecko G201X drives

The problem is that the motors move in an erratic manner and make a horrible growling noise that resonates through the machine.  It should be running at 600IPM on the rapids but instead is running at about 150, give or take, and bucking and jerking to the point that this 2000 pound machine is moving.  It's a plasma with a 250 pound gantry.

Here's what I've checked...

- Power supply has a clean 63V while the axis is moving, so I know I have enough power.

- Driver test is clean.  Nice flat line.

- Adjusted the Gecko's with no difference.

- Adjusted acceleration up and down and still get growling erratic motion.

- With the electronics shut down, you can move all axes by hand and motion silky smooth.  No binding anywhere.

Any ideas on what could be causing this?  I've used the every component before except the PMDX-122 BB.  Could there be a setting in Mach that I'm missing?

Thanks

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: New setup...and having a problem.
« Reply #1 on: May 30, 2011, 04:57:20 PM »
I seem to have it in the back of my mind that the geckos have a jumper for use with big steppers, what size are your steppers?
Hood
Re: New setup...and having a problem.
« Reply #2 on: June 01, 2011, 06:41:30 PM »
Found the problem.  The new G201X drives are capable of running with either a common ground or 5V, but the state of the step signal has to match.  I'm using a 5V common, so I changed the state of the step pulse to active low and it all works great.  When I checked "Sherline" mode and it worked, I knew it had to be a pulse issue, which a call to Gecko confirmed.