Hello Guest it is February 28, 2021, 08:58:02 PM

Author Topic: HELP! My Z axis is moving in chunk steps  (Read 3722 times)

0 Members and 1 Guest are viewing this topic.

HELP! My Z axis is moving in chunk steps
« on: May 24, 2011, 10:41:08 AM »
Here is the problem.
I have a 4th axis machine where A is the chuck X moves the length of the object being machined and Z is the depth.
The A axis keeps a perfect continuous RPM and the X axis is moving constantly at say the rate of 128th of an inch per second and the servo motor for the X has a constant smooth rotation. However the Z axis servo is not moving except every few seconds and it then moves about 10deg instead of much smaller say 1/2 deg steps. Is there a setting I am missing or is my G-Code wrong?

A Few Facts
All 3 axis are Yaskawa Servos
Z axis is a ball screw driven by a 10:1 gearhead

Here are a few line of G-Code
N000035     A1440 X0.077 Z-0.00281176075414713;
N000036     A1440 X0.077 Z-0.00285099436525282;
N000037     A1440 X0.077 Z-0.00288965724492307;
N000038     A1440 X0.077 Z-0.00292777388626453;
N000039     A1440 X0.077 Z-0.00296536717817242;
N000040     A1440 X0.077 Z-0.00300245854969372;
N000041     A1440 X0.077 Z-0.00303906809810783;
N000042     A1440 X0.077 Z-0.00307521470288652;
N000043     A1440 X0.077 Z-0.00311091612742498;
N000044     A1440 X0.077 Z-0.00314618911008591;
N000045     A1440 X0.077 Z-0.00318104944591235;
N000046     A1440 X0.077 Z-0.00321551206015691;
N000047     A1440 X0.077 Z-0.00324959107459355;

Thanks in advance
Curtis
Re: HELP! My Z axis is moving in chunk steps
« Reply #1 on: May 24, 2011, 01:08:44 PM »
Majke one more mention, the DRO for Z axis shows slow continuous motion

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: HELP! My Z axis is moving in chunk steps
« Reply #2 on: May 24, 2011, 04:30:20 PM »
Is it ok if you command a Z only move?
Not really sure what you are meaning when you say Z moves 10deg steps, Z is normall a linear axis.
What are your steps per unit for the Z
Hood

Offline Sage

*
  •  365 365
    • View Profile
Re: HELP! My Z axis is moving in chunk steps
« Reply #3 on: May 24, 2011, 05:00:50 PM »
Had me confused as well. I think what he's saying is the shaft of Z servo moves only 10deg at a time. Shaft turns pulley, pulley drives Z-axis linearly.

I'm wondering if it's simiilar to the issue that I was helped with which turned out to be turning on exact stop instead of constant velocity (or maybe it was the reverse)?

Sage.
Re: HELP! My Z axis is moving in chunk steps
« Reply #4 on: May 24, 2011, 10:38:08 PM »
Yes the shaft that is between gearhead and ballscrew.
Or in other words the Z axis is moving 0.00292777388626453 in one move not slowly as the other 2 axis are

even if I run the G01 in front of each line that does not help
2 out of 3 axis seem to provide smooth linear interpolation.

To better understand I am machining the outside surface of a cone shaped fiberglass shell starting at the biggest diameter and working down to the smallest while the A axis is spinning. The real problem is it is leaving machining marks every time the Z axis lowers.

I have G64 in the start line

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: HELP! My Z axis is moving in chunk steps
« Reply #5 on: May 25, 2011, 10:19:24 AM »
As said earlier, what are the steps per unit of the Z and does it perform fine if a Z only move is made?
Hood
Re: HELP! My Z axis is moving in chunk steps
« Reply #6 on: May 25, 2011, 12:21:18 PM »
Yes the Z axis moves smooth if the line looks like this
N1000 Z 1.00;

Here are all my Motor settings
Z
Steps = 50911
IPM = 53.034
Accl = 2000

X
Steps = 1015.4
IPM = 49.99
Accl = 2000

A
Steps = 56.89
IPM = 6666  (is truely degrees of rotation)
Accl = 80000

Thank You
Curtis

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: HELP! My Z axis is moving in chunk steps
« Reply #7 on: May 25, 2011, 01:31:12 PM »
In the above code can you edit to remove the A and X moves just leaving the Z moves and see if the same happens. You are not moving A and X so it would be interesting to see if the Z still stutters with them removed. Your motion is very small and it could possibly be your tuning.

Hood
Re: HELP! My Z axis is moving in chunk steps
« Reply #8 on: May 25, 2011, 02:16:37 PM »
Ok tried it with 20 lines and had to slow it way down, because 20 line is only about 1/16 of an inch.
With out it being slowed down it went real fast on fast movement
After slowing it down it readover half the line before it even moved at all.

So I then tried to make the movement a lot larger like .1 inch each and it still chunked the movements instead of a smooth fluid motion.

Is there a setting I am missing ?

BTW, it jogs very smooth and it you tell it in Gcode to move by it self up and down inches it is very smooth and continuous

Thank You
Curtis

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: HELP! My Z axis is moving in chunk steps
« Reply #9 on: May 25, 2011, 02:28:05 PM »
It sounds to me as if your tuning may be very loose and the axis (with gearhead) may have some stiction.
If you attach your xml I will have a look but as the DROs in Mach move smoothly I would say it is more likely your servo tuning or possibly even the drive parameters.
Hood