Hello Guest it is September 29, 2020, 04:01:23 AM

Author Topic: Mach skips lines: what's going on?  (Read 1905 times)

0 Members and 1 Guest are viewing this topic.

Mach skips lines: what's going on?
« on: May 24, 2011, 09:10:35 AM »
I've written a very simple program for Mach3, and running it in simulation on my laptop, it skips the first few moves and goes straight into the g03 from where it is. Needless to say this is a right old nonsense.

My laptop is a 64 bit Winows 7 Professional machine, and the error occurs in regualar W7 and XP mode.

G64 G21 G15 G40 G49
G0 Z20
G0 X0 Y150 {STARTING POSITION}
G41 P6.00
G0 X3.75 Y0
G03 X 3.75 Y0 I32 J0
M30
%

I've tried littering it with dwell commands to try to prompt it to find the first few lines but to no avail. I've also tried replacing the initial rapids with fast g01 commands, and repeating the first move to the starting position several times. It just starts from where it is and gets into the G03 move. I'm stumped.

Any ideas?




« Last Edit: May 24, 2011, 09:15:51 AM by BluePinnacle »

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach skips lines: what's going on?
« Reply #1 on: May 24, 2011, 09:15:47 AM »
Running Mach without the driver is known to have some weird happenings so likely your problem.
Hood
Re: Mach skips lines: what's going on?
« Reply #2 on: May 24, 2011, 09:17:18 AM »
ok, cheers - Will reinstall wiith the driver in place and report back.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach skips lines: what's going on?
« Reply #3 on: May 24, 2011, 09:18:47 AM »
You cant, driver doesnt run in 64bit OS

Hood