Hello Guest it is June 18, 2019, 06:13:19 PM

Author Topic: CNC Wrapper HELP!  (Read 6875 times)

0 Members and 1 Guest are viewing this topic.

CNC Wrapper HELP!
« on: May 10, 2011, 01:32:59 PM »
I am having a hard time believing that no one else is having this problem. I have a 4th axis on my router that works fine with the spline and gear cutting wizards in Mach. I have tried all that the help file says to do to set up the code, but when I run it, it does'nt even remotely do what it is supposed to do. I have the licenced version so that shouldn't be an issue. I have tried to contact them with these issues, but I have yet to get a responce. If someone out there has a working 4th axis set up that they would like to help me with, I would really appreciate it

Offline BR549

*
  •  6,871 6,871
    • View Profile
Re: CNC Wrapper HELP!
« Reply #1 on: May 10, 2011, 01:50:57 PM »
SO exactly WHAT is it not doing correctly ?

(;-) TP
Re: CNC Wrapper HELP!
« Reply #2 on: May 10, 2011, 02:20:11 PM »
Well, when I run a code that has been created, The a axis will start turning at an extremely slow rate,(4 degrees/min). I think I may have fixed this by adding a new tool in my original cam program with a feed rate of 1300 units per min. It still does odd moves like, rotates the axis several times before making any y or z moves.I also have loaded some of the sample wrapps to Mach and they look nothing like they do on the web site. It looks like a one demensional drawing that makes no sence. Any ideas? Thank you for your responces.I feel like the only kid in class that does'nt have a working 4th axis.
Andy.

Offline BR549

*
  •  6,871 6,871
    • View Profile
Re: CNC Wrapper HELP!
« Reply #3 on: May 10, 2011, 03:16:11 PM »
oK  in mach config, go down to toolpath. Under rotations select Axis of rotation, A enable and USE radius for feedrate.

Next on the settings page under rotation radius set teh A axis radius to your part radius.

Give that a try. (;-) TP
Re: CNC Wrapper HELP!
« Reply #4 on: May 10, 2011, 08:52:39 PM »
I think I figured out my main problem. Under general config, I had the Rot 360 rollover checked. Before I just saw a big blue ring where the toolpath was. I noticed that in cnc wrapper, all a axis moves were from 0 to -360. My machine was set up to run from 0 to +360. I'm not sure what most of the options are or what they do in the config screen so I am reluctant to change them if they are already selected. Thank you very much for your help BR549, I'm sure I will have more questions as I go along. Andy.

Offline Greolt

*
  •  956 956
    • View Profile
Re: CNC Wrapper HELP!
« Reply #5 on: May 11, 2011, 02:00:30 AM »
Regarding the 0 to -360, if you have your rotary axis direction as per convention then this is normal and correct.

It is important to know that CNCWrapper does not do any gcode manipulation beyond changing the relevant axis designation ( for example change Y to A) and scale those positions as per the designated diameter.

That is all it does.  Any further problems are there in the original code.  CNCWrapper did not introduce them.

Regarding the rotary axis compensation that Terry mentioned above, here is a copy of a post I made a while ago,

=======================================================================================

All axis move in units per min.   With a rotary axis those units are degrees.  

So what is 60 ipm on the linear axis (desired speed of the tool in the work), is 60 degrees per min for the rotary.

That 60 degrees per min angular feedrate will make the tool move through the work at a speed dependant on the distance the tool is away from the centre of rotation. (in your case, very slowly)

So Mach has a feature to compensate the rotary axis feedrate, to accommodate differing radius that the tool is cutting at.

It is activated via the Toolpath Setup menu.   Check "Use Radius for Feedrate"  All the other settings in this box are to do with the toolpath display window.

On the Settings page there are three DROs labelled "Rotation Radius".  IMO they would be better labelled "Rotation Offset Radius"

They are to tell Mach the distance that the relevant axis origin (Z in this case) is offset from the centre of rotation.  (A axis in this case)

So if you are machining on the outer surface of a 10 unit diameter job and Z axis origin (zero) is set on that outer surface, then the correct value for the "Rotation Offset Radius" DRO is 5.  The distance that Z origin is OFFSET from centre of rotation.

If, on the other hand, the Z axis origin is at the centre of rotation (my preferred method for most jobs) then the correct value for "Rotation Offset Radius" DRO is zero.  The distance that Z origin is OFFSET from centre of rotation is zero.

Mach takes the Z axis DRO value and the "Rotation Offset Radius" DRO value and adds them together to ascertain at what radius the tool is cutting at any one time.  Then compensates the angular feedrate to have the tool move through the material at the desired speed.

Maximum velocity as set in motor tuning is honoured, so that will always be the upper feedrate limit.

Now there is one little "Gotcha".   A zero value in the "Rotation Offset Radius" DRO will automatically disable the entire feedrate compensation feature.  This is a known bug and is being addressed by Artsoft at this time.  Hopefully it will be fixed soon.

The workaround for this, is to use a very small value (eg. 0.001) in the "Rotation Offset Radius" DRO when zero is the correct and desired value.  Small enough to have no measurable effect on feedrate, but not zero.

Hope this helps,

Greg