Hello Guest it is March 06, 2021, 12:14:50 AM

Author Topic: Asolutely dumbfounded guy!????  (Read 6045 times)

0 Members and 1 Guest are viewing this topic.

Asolutely dumbfounded guy!????
« on: May 09, 2011, 01:56:57 AM »
First Id like to thank everyone who fields these questions. I've found amazing info in the various forums on line. Enough info in fact to build a nice little 18" x 30" x 6" router. It's turned out great, I've even cut a couple of parts, but i have a nagging problem. I'm trying to get my motors to run smoothly and have been experimenting with a lot of different speeds and acceleration to try to acheive this. Whats puzzling is that if have the motor tuning dialog open I can get them to move smooth as butter at top speed (25,000 mhz). But then when I close that window and am jogging the motors they run really poorly. I'm running a g540, mach 3, 48v power, 12 amps, and 381 oz in motors. If anybody would like the specs on the motors I can supply those also. I bought them through keiling, for what it's worth. Thanks all for taking a minute to read this. I've spent hours searching for the solution, and am finally throwing in the towel and asking for help. Thanks again!!!!

Ben Wood

Offline Tweakie.CNC

*
  • *
  •  8,664 8,664
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Asolutely dumbfounded guy!????
« Reply #1 on: May 09, 2011, 02:56:28 AM »
Hi Ben,

Welcome to the forum.
Just a couple of bits of info taken from the Gecko website.......


Your step pulse width must be at least 2uS wide and the pulse polarity for the step and direction signals are ACTIVE HIGH.

STEP 7: ADJUST TRIMPOT

The G540 is composed of four individual G250 motor controls, each of which has a trimpot on board to adjust low speed smoothness. In your CNC program set the axis being adjusted to move at 2 revolutions per second and use a non-conductive screwdriver to turn the trimpot in the ADJUST hole on the top of the drive. If you do not have a non-conductive screwdriver you may use a standard screwdriver, but be careful not to touch any components other than the trimpot. The trimpot has 270 degrees of motion and will have an audible “sweet spot” when it is in proper position. This position will change with each motor so be sure to readjust if you change motors.


Don't know if this helps,

Tweakie.
KEEP SAFE !

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Asolutely dumbfounded guy!????
« Reply #2 on: May 09, 2011, 04:20:22 AM »
Whats puzzling is that if have the motor tuning dialog open I can get them to move smooth as butter at top speed (25,000 mhz). But then when I close that window and am jogging the motors they run really poorly.
Mach screen updates are suspended whilst the tuning dialog is open. I'm thinking this may allow the driver to perform better than it can when Mach is busy doing it's thing.

Ian
Re: Asolutely dumbfounded guy!????
« Reply #3 on: May 09, 2011, 10:38:02 AM »
thanks for your responses. The steppers ran so well at low speed that I skipped the trim pot adjustment. I'll go back and do that along with adjusting the pulse width and the ports and pins settings. It sounds like these are things I should check anyway.

The fact that Mach runs differently when that window is open, makes me think that it's my computer system. I'll spend some time going through the list of "house keeping" steps to see if anything helps. Thanks so much for your help!

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: Asolutely dumbfounded guy!????
« Reply #4 on: May 09, 2011, 11:12:48 AM »
I've heard of this issue before, and I think you're correct, that it's a PC issue. Try running task manager while doing the testing, and see if the CPU load goes up drastically when the motor tuning is closed.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Asolutely dumbfounded guy!????
« Reply #5 on: May 09, 2011, 10:23:52 PM »
Thanks for the help Gerry! I opened the tuning dialog and it takes about 1% of the CPU to jog one axis. Then with the dialog open it takes about 18%-24% just to jog one axis. I'm so happy to know where the problem is, Thanks! Now I need to deal with it, but i could use some advice. I feel like i have a few reasonable options. Is there basic house keeping I can do on the computer to make the cpu more efficient. I could add a graphics card if it would help significantly. Or is a faster CPU the best solution. Right now i have to slow things to about 2000mm per min to run smooth, and with the dialog open I can run it at about 10,000 and it's still smoother. For what's it's worth I'd be interested in fielding anyones opinion. This has been driving me crazy for a week. Thanks.

Ben

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: Asolutely dumbfounded guy!????
« Reply #6 on: May 10, 2011, 01:12:04 AM »
What are the specs of the PC?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Asolutely dumbfounded guy!????
« Reply #7 on: May 10, 2011, 03:41:22 AM »
It's a HP dx2200, The processor is a pentium 4, 3.06 ghz unit. And I believe it has 2 gigs of ram. Should I dig up any more info?

thanks
Re: Asolutely dumbfounded guy!????
« Reply #8 on: May 10, 2011, 03:55:41 AM »
Make sure that it isn't using shared memory for the on board video.
A non integrated video card may make a big difference and is easy to try if you have a spare card lying around.

Mike
We never have the time or money to do it right the first time, but we somehow manage to do it twice and then spend the money to get it right.

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Asolutely dumbfounded guy!????
« Reply #9 on: May 10, 2011, 09:11:14 AM »
An add-in video card may indeed help. If you look in the downloads section of this site you will find a Mach optimization guide for Windows XP as well. One item with the G540 is that it does not like really short step pulses that Mach can sometimes provide. You can try turning on 'Sherline' mode on the first page or Ports&Pins to see if that helps (it tells Mach to send out wider pulses.)

The worst case scenario is that your PC may not be up to the task, a new PC or external motion control card would be the options then.
Happy machining , Jeff Birt