Hello Guest it is November 22, 2019, 08:09:35 AM

Author Topic: Problem overriding a tripped limit switch  (Read 8045 times)

0 Members and 1 Guest are viewing this topic.

Problem overriding a tripped limit switch
« on: May 08, 2011, 05:37:49 PM »
Hello, I asked this in the general forum and they thought I should ask here too as it may be a Galil problem.

Alright, I recently wired up all my homes and limits. During testing I intentionally ran into a limit, Mach went to EStop and the servo drives went in to standby. Great so far. Then I hit the "Override Limits" button and reset Mach. The servos enabled BUT Mach never came out of EStop. The servos are active, Mach is in EStop mode and there is no way to move the axis or disable the servos without powering down and manually moving the axis off the switch.

So, that's the problem I have. Any help would be appreciated.

Here's a quick video of what I explained above.

http://www.youtube.com/watch?v=faIeQWPUctU

Offline kcrouch

*
  •  193 193
  • In way too deep!!!
    • View Profile
Re: Problem overriding a tripped limit switch
« Reply #1 on: May 09, 2011, 11:18:52 AM »
You got me interested! i went out and tried just what you did on my lathe with 2153 Galil and Yaskawa drives. I use prox switches for homes and limits. My settings are as follows:
config Galil limits active low - unchecked.
config Galil homes active low - checked.
ports and pins homes and limits - enabled and active low unchecked.
auto limit override - checked.
no axes reversed in homing/limits.

Used MPG to jog into limits, tripped and caused limit error as expected.
clicked on reset, got beep, used MPG to jog off limit sucessfully!!!!
clicked again on reset to clear limits message, everything still working!

Your trouble may be caused by one of these settings. I am not sure how your switches are wired n-o or n-c, so can't comment on that. It took me some time to find the correct settings for my machine, but it is working very well.
Please try wiring your switches n-c and your settings should end up similar to mine.

Kenny
Having way too much fun! Something must surely be wrong.

Offline kcrouch

*
  •  193 193
  • In way too deep!!!
    • View Profile
Re: Problem overriding a tripped limit switch
« Reply #2 on: May 09, 2011, 10:00:12 PM »
A bit more information. Checking the active low boxes in the plugin is the same as setting Galil "CN1" for limits and "CN,1" for home. Leaving unchecked is the same as setting "CN-1" for for limits and "CN,-1" for home.
Hope that this helps to troubleshoot.
Kenny
Having way too much fun! Something must surely be wrong.
Re: Problem overriding a tripped limit switch
« Reply #3 on: May 09, 2011, 10:43:00 PM »
Played with it for a few minutes tonight. Noticed that if I turn off (disable) the limits in ports and pins the Galil hardware will stop the axis motion in the direction of the switch and will allow me to jog away from the switch. Suppose I could let the Galil hardware handle the limits and homes and just have it send a signal to Mach if a limit is tripped??

Anyway, I'll keep picking at it. I want to try making a new profile from scratch, maybe there's some odd setting that got changed.

Offline kcrouch

*
  •  193 193
  • In way too deep!!!
    • View Profile
Re: Problem overriding a tripped limit switch
« Reply #4 on: May 10, 2011, 08:06:32 AM »
I believe that you have one state set for the Galil and possibly the opposite state set for Mach3. It will take a bit of trial to sort it out, but it will work fine when correct.
Kenny
Having way too much fun! Something must surely be wrong.
Re: Problem overriding a tripped limit switch
« Reply #5 on: April 19, 2012, 06:11:18 AM »
Hi, I am doing a first time installation of galil (& mach3 with it). I have encountered the same issue like above and have left the limit switches unchecked (disabled) in mach3 ports&pins. I am still having problems with the home switch setting. the configuration on my machine is: 2 limit switches for each axis that are normally open. they are configured disabled in mach3.   
this allows me to jog up to the limit, and then only jog in the opposite direction (like it should). now I want to use one of the switches as a home and here the problem starts: if I leave the home unchecked in the ports&pins config then  when i press the "ref" nothing moves and the "ref" button turns green without any movement. If I enable the homing input in ports&pins and press"ref" it moves towards the limit switch and stops on the limit but the "ref" button doesnt turn green and i cannot jog any of the axes without reseting the controller. the checkbox "use limits as home switches" is checked but it has no influence. "home x" is assigned to pin 17 and i have tried working with the switch wired only to the limit input and also with the switch wired both to the limit input and home input. if you have any suggestions I will be grateful :)
Re: Problem overriding a tripped limit switch
« Reply #6 on: April 22, 2012, 10:02:47 PM »
ittai, I can't give you any advice myself. Sounds like you have tried all the combinations though. I never bothered to "fix" my limit switch problem because the machine works ok the way it is. I have seperate home switches before the limit switches, so I never hit limits unless I am doing something wrong and even though I cannot drive off the limit the most inportant thing to me that the limit does stop the machine. I just have to manualy move the axis off the switch.

I would suggest setting your limits up as normaly closed. Others are using N.C. switches and have no problems.