Hello Guest it is January 19, 2020, 02:09:48 PM

Author Topic: Timing Issues in Mach but driver test is good  (Read 4451 times)

0 Members and 1 Guest are viewing this topic.

Timing Issues in Mach but driver test is good
« on: May 08, 2011, 05:22:39 PM »
Hello

Having been running Mach for years one of my CNC PCs threw a wobbly (well windows to be precise!) and I've had to complete a fresh install of windows and Mach 3. I've now hit a problem that has got me banging my head against a brick wall! When I run the drivertest I get a good constant pulse and the system is described as excellent. However when I start Mach the first thing is it takes about 10 seconds before the screenset appears. Thne if i go into diagnostics the pulse timing i get a couple of seconds of timing at abround 25000 then a few seconds down at about 30, then back to 25000, then 30 ish and so on.

I've done a fresh install of WinXP following the optimisation guide on a clean drive, changed the graphics card and the ram, removed everything bar the essentials. The PC in question has happily run my mill for the past couple of years.

Any help would be much appreciated.

Cheers

Dave
Re: Timing Issues in Mach but driver test is good
« Reply #1 on: May 08, 2011, 06:15:32 PM »
Do you have onboard pport or a pci card? I would check the bios fist

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Timing Issues in Mach but driver test is good
« Reply #2 on: May 09, 2011, 05:15:28 AM »
Sounds like the driver is not playing well with your system. First thing I would try is go into device manager and delete the Mach driver then go to the Mach folder and run the driver test, that will reinstall the driver.
What version of Mach are you running?
Hood
Re: Timing Issues in Mach but driver test is good
« Reply #3 on: May 11, 2011, 04:28:35 PM »
Thanks for taking the time to reply

The parallel port is onboard and built into the motherboard. I've had a look through the bios and turned everything non-essential off and have also tried setting the bios back to its defaults

I tried deleting the driver and running the driver test again but the same issue came back. I've installed the latest lockdown version of Mach.

The annoying part is that this PC used to run Mach brilliantly - tried lots of things and still no success :(

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Timing Issues in Mach but driver test is good
« Reply #4 on: May 11, 2011, 05:52:28 PM »
Download an older version of Mach from the FTP site and see if that changes things.
Hood
Re: Timing Issues in Mach but driver test is good
« Reply #5 on: May 15, 2011, 12:54:56 PM »
It's taken me a while and a lot of experimenting but I have found that Mach version 3.042.033 is the last one that will succesfully run on my PC. Any version after this gives me terrible timing issues.

Is there a fix for this or am I limited to this version?

Cheers

Dave

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Timing Issues in Mach but driver test is good
« Reply #6 on: May 15, 2011, 01:14:20 PM »
Make sure ACPI is disabled in the BIOS before installing Windows. With a clean install, that should be the only optimization that needs to be done.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Timing Issues in Mach but driver test is good
« Reply #7 on: May 15, 2011, 01:39:56 PM »
There were a lot of driver changes from 034 onwards that were done for threading, that could well be where your issues are coming from.
Hopefully Gerry's suggestions will help, but maybe an email to andrewm@machsupport.com detailing that you have issues with drivers after the 033 version may bring some suggestions.
Hood

Offline Tj256

*
  •  45 45
    • View Profile
Re: Timing Issues in Mach but driver test is good
« Reply #8 on: May 15, 2011, 06:34:01 PM »
I've found that ACPI can be left on-- For me it's usually the power management / CPU throttling settings that must be turned off. Under advanced power options, force the minimum / maximum processor state to 100%