Hello Guest it is January 17, 2022, 10:29:22 AM

Author Topic: halfmoon instead of circle  (Read 16763 times)

0 Members and 1 Guest are viewing this topic.

Re: halfmoon instead of circle
« Reply #50 on: May 10, 2011, 04:31:48 PM »
ok so I got a c11 from cnc4pc and got it all up and going (the bob I had was junk) now I have a thc problem.  The thc tries to move the head up when it should be moving down, and my y and a axis seem to forget they are to go in the same direction.  I have to go into ports and pins set y to active low and appy, then go back in and set it to active low then click a as no slave then a as slave and they work again untill the next time I open mach3. 

I should have bought a new machine, this being down for 3 weeks has pissed off several customers and we have lost several orders.  Not to mention my sanity is now on the line.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: halfmoon instead of circle
« Reply #51 on: May 10, 2011, 04:41:34 PM »
Can you attach your xml please.
Hood
Re: halfmoon instead of circle
« Reply #52 on: May 10, 2011, 04:53:38 PM »
Here you go.
Re: halfmoon instead of circle
« Reply #53 on: May 10, 2011, 04:55:42 PM »
I switched ports to see if that was the problem so it will read all motors on port 2 and the thc on port 1

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: halfmoon instead of circle
« Reply #54 on: May 10, 2011, 05:03:41 PM »
Initial looks it seems fine, possibly try Sherline mode and see if that helps.
Hood
Re: halfmoon instead of circle
« Reply #55 on: May 10, 2011, 05:17:33 PM »
Thank you Hood.  I restarted mach 5 times after switching it over to sherline and my a stays a slave to my y.  I'll be trying the z movements come morning, cause I want to end my day on a better note then it started.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: halfmoon instead of circle
« Reply #56 on: May 10, 2011, 05:19:50 PM »
Hopefully thats it.
Hood
Re: halfmoon instead of circle
« Reply #57 on: May 11, 2011, 10:06:37 AM »
I wish this was it.  So my thc is running and says it's moving my z+ mach says my zis moving + but the z goes -.

Yet when my z is moved with the hotkeys it does what it is supposed to do.

And after shutting down mach3 and restarting it several times this morning my y a and z had to get switched to active low cause they started moving in the wrong directions again.

Offline OCNC

*
  •  23 23
    • View Profile
Re: halfmoon instead of circle
« Reply #58 on: May 11, 2011, 12:13:48 PM »
How are your signal cables?  Is there any chance you have an intermittent short or crosslink in a cable?

Chris
Re: halfmoon instead of circle
« Reply #59 on: May 13, 2011, 12:19:00 PM »
Ok so I completely wiped the computer again, and it has seemed to fix everything now.  But I do have one last problem now when cutting.  The tch does not seem to move the z any direction.