Hello Guest it is May 25, 2019, 12:24:17 AM

Author Topic: Crop circles in Cut2d  (Read 3861 times)

0 Members and 1 Guest are viewing this topic.

Crop circles in Cut2d
« on: April 16, 2011, 10:29:10 AM »
I have been using Mach 3 for years with an old program that creates gcodes and is no longer working. I am trying to replace it with Cut2d, but when I open my file in Mach it has extra circles. Tony at Cut2d said that In Mach3 you need to change the Circular Arc I J settings to be Incremental moves. He sent me a picture of the general logic configuration page that has an IJ mode. My logic page looks like the picture I have uploaded. I am in dire straits and need to get this program to work. Any help would be greatly appreciated. My mill is down! Thanks Joe

Offline pgh3

*
  •  21 21
    • View Profile
Re: Crop circles in Cut2d
« Reply #1 on: April 16, 2011, 11:28:36 AM »
Hi jrich124,
I think he means that the I and J parameters have to be in Incremental mode rather than Absolute mode. You put a G91 into your code just before the command that uses I and J.
Your parameters then move relative to the current spindle position; and not from the origin position (X0, Y0).
When the G2 or G3 or whatever other code uses I and J are finished, make sure you put in a G90 to tell Mach3 you want to be in Absolute mode.

For example, (this is for a mill)

G90        (set machine to Absolute mode)
G0 X10   (Rapid movement of the spindle to 10 units in X)
G91        (set machine to Increment mode)
X-2          (spindle will rapid to 8 - not back to to -2)
G90        (back to Absolute mode)

You will see that having the correct mode is extremely important for preventing a crash!
On your first picture, you can see that your machine has initialized to Absolute mode with the G90

These commands are to be written into your part code; they are not available as part of the configuration of the Mach3
software
When you are in the Mach3 screen, click on the G-Code button and look through the list - you will be able to read a description about each G code there.

Cheers,
Peter
« Last Edit: April 16, 2011, 11:41:46 AM by pgh3 »
Re: Crop circles in Cut2d
« Reply #2 on: April 16, 2011, 11:41:37 AM »
That second screen shot doesn't look the General Config screen I have.  You should see a option for setting the IJ Mode.  If you've set IJ Mode properly in Mach and it is still in absolute IJ mode, which is usually the cause of crop circles, then look at the header in your code and make sure there is NOT a G90.1 anywhere in the code.  While you're there, add a G91.1 to the program header.  This will force Incremental IJ Mode regardless of how it is set in Mach general config.

The above post is referring to absolute/incremental positioning, not arc IJ mode.  They are two separate things.  The problem you describe is usually caused by improperly set arc IJ mode.  G90/G91 switch distance mode.  G90.1/G91.1 switch IJ Mode.

G90.1 = Absolute IJ Mode
G91.1 = Incremental IJ Mode

  
« Last Edit: April 16, 2011, 11:50:51 AM by rrc1962 »