Hello Guest it is June 16, 2019, 05:37:54 PM

Author Topic: Strange problem: goes exact mode after mdi  (Read 4096 times)

0 Members and 1 Guest are viewing this topic.

Re: Strange problem: goes exact mode after mdi
« Reply #10 on: March 28, 2011, 10:47:51 AM »
Hi Hood,

>The CV LED is staying lit but the feedrate DRO definitely shows a slow down.
The  feedrate slowdown definitely is because it is moving as it would in Exact Stop mode.

>Doing a RFH after the hold, stop, MDI seems to make it ok and I suppose really thats the way you should do it but I will see if I can get a hold of Brian and see what he has to say.
RFH could even be more like a workaround than the  way to do it depending on the circumstances.  With large programs it may be counted in minutes the wait for RFH to "reread" the entire code, is you want to stop and go several times (for whatever reason) it may become very slow.

Thanks for your help!
Luis

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: Strange problem: goes exact mode after mdi
« Reply #11 on: March 28, 2011, 10:51:10 AM »
I skyped Brian to ask him to take a look but he has not responded so I think you would be best to email support and point to the thread or give details in your email.
Hood

andrewm

*
Re: Strange problem: goes exact mode after mdi
« Reply #12 on: March 29, 2011, 01:32:31 PM »
I ran it just now and saw the problem, I'll look into it further and email you back.

andrewm

*
Re: Strange problem: goes exact mode after mdi
« Reply #13 on: March 29, 2011, 02:59:23 PM »
The reason it is slowing down is that the modal state of the program is wrong and will always slow down because there is no CV for Rapids. Thus, once you MDI a G0 of any kind you must then set the modal state back by issuing a MDI G1, Or by using the RFH button, which puts it back to the right settings.
Re: Strange problem: goes exact mode after mdi
« Reply #14 on: March 29, 2011, 06:54:26 PM »
Oh...!!!!! That's it!  Solution was very simple but elusive!  (at least for me S:

Thanks!