Hello Guest it is May 19, 2019, 02:59:57 AM

Author Topic: Mach3 Rebooting on Startup again - Is Smooth Stepper the solution?  (Read 2397 times)

0 Members and 1 Guest are viewing this topic.

Offline Phase

*
  •  15 15
    • View Profile
Hi.

It seems random.  You start Mach3 and after a few seconds the computer reboots.  After the computer reboots and windows comes back you start it up again and cross your fingers.  You have to keep trying until Mach loads up successfully.

I had this problem 2-3 months ago and after reinstalling XP and Mach3 from scratch the problem went away... until this week.

Is this caused by the printer driver?

I can not be rebuilding the computer ever 2-3 months.  Would using smooth stepper instead prevent this problem?

If so, is there a way to uninstall the printer driver or do I have to reblast the machine?

Thanks!

andrewm

*
Re: Mach3 Rebooting on Startup again - Is Smooth Stepper the solution?
« Reply #1 on: March 21, 2011, 11:37:09 AM »
What does your drivers test look like?

You could try re-installing the Driver and see if that helps. To uninstall the driver just go into your device manager, find the driver and uninstall it.
« Last Edit: March 21, 2011, 11:42:16 AM by AndrewM »

Offline Phase

*
  •  15 15
    • View Profile
Re: Mach3 Rebooting on Startup again - Is Smooth Stepper the solution?
« Reply #2 on: April 07, 2011, 08:49:14 PM »
The tests showed "excellent" but the problem remained.

After a lot of trial and error it seems to be fixed.  Somehow a few of the windows services either turned themselves on when they were previously off, or somehow they started to interfere.  So I went in and started turning things off.

Attached is the screen capture of the services configuration utility in XP with the settings that seem to work... in case anyone else runs into this.

I was going to get the smooth stepper, but just the thought of having to mess with it all over again... oh well, may be next time.
« Last Edit: April 07, 2011, 08:56:37 PM by Phase »

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Mach3 Rebooting on Startup again - Is Smooth Stepper the solution?
« Reply #3 on: April 09, 2011, 11:19:43 AM »
From your description it is very hard to tell if you have a PC problem or Mach problem. If it is related to Mach I would suspect it would be something with the parallel port driver. One test would be to remove the parallel port driver and see if your PC still acts up. (Of course you can't run your machine with the driver missing.) If your PC does not act up with the driver removed you could try to use the special driver (run specialdriver.bat in mach directory to install it.)

As everyone knows I'm a big SmoothStepper fan and my inclination would be to ditch the parallel port.
Happy machining , Jeff Birt