Hello Guest it is October 18, 2019, 03:33:10 PM

Author Topic: Setting up Homing  (Read 6156 times)

0 Members and 1 Guest are viewing this topic.

Offline kf2qd

*
  •  123 123
    • View Profile
Setting up Homing
« on: March 17, 2011, 09:30:24 AM »
As delivered my KX3 did not have homing configured. I started out manually homing, but decided it would be nice to have the homing process automated. The process should be the same for the KX1 and it appears that some of them have teh same error in the config that I found.

The initial step to configurring homing is to make sure the limits are set up properly. Go to the Config Menu, select Ports & Pins and then select the Input Signals tab. As shipped the the table looked something like this - (only the necesay collumns shown)

Signal     Enabled   Port #    Pin Number   Active Low   
X++       Green     1            11              Green
X--         Green     1            11              Green
XHome   Red        1            0                Red
Y++       Green     1            12              Green
Y--         Green     1            12              Green
YHome   Red        1            0                Red
Z++       Green     1            13              Green
Z--         Green     1            13              Green
ZHome   Red        1            0                Red

I Changed the XHome, YHome &ZHome to match the other entries for those axis so now the table looks like this -

Signal     Enabled   Port #    Pin Number   Active Low   
X++       Green     1            11              Green
X--         Green     1            11              Green
XHome   Green     1            11               Green
Y++       Green     1            12              Green
Y--         Green     1            12              Green
YHome   Green    1             12              Green
Z++       Green     1            13              Green
Z--         Green     1            13              Green
ZHome   Green    1             13              Green

It may seem strange to use the same input for all fuctions on an axis but Mach is able to figure it all out.
I clicked on Apply and closed that window.
I then Cliked oon Config and Homing/Limits.
Z axis wants to home full up. X & Y really don't matter, I home Y full forward and X full to the right.Puts the table at a nice place to change parts.

The necesary changes to this tabel were -
X Axis - Home Negative - Green
If you want the X Axis to home to the left leave the Home Negative Check red.

Now at this point I attempted Homing and the Z Axis would go to the top and hit the limit and the Z Dro would just keep counting. It turns out that the X & Z Input Pins were swapped.
I had to make the Input Signals look like this -

Signal     Enabled   Port #    Pin Number   Active Low   
X++       Green     1            13              Green
X--         Green     1            13              Green
XHome   Green     1            13               Green
Y++       Green     1            12              Green
Y--         Green     1            12              Green
YHome   Green    1             12              Green
Z++       Green     1            11              Green
Z--         Green     1            11              Green
ZHome   Green    1             11              Green

and then Homing worked perfectly.

There is a way to check how you machine is hooked up - at the bottom of the Input Signals there is a button labeled Automated Setup of Inputs. Click this button and a new window opens and in the pick box it will say X-Limit Switch ++ and next to it is a button the says Autoset - click this button and then trip one of the X Axis limits and the little message box will say Signal set to Port#1 Pin ??. Select next Signal. if the 2 question marks say 11 then the machine should home using the factory settings, it the ?? is 13 then all the XAxis pins need to be 13 and the Z Axis pins need to be 11.

Offline kf2qd

*
  •  123 123
    • View Profile
Re: Setting up Homing and Soft Limits
« Reply #1 on: March 17, 2011, 09:32:37 AM »
Once you have homing setup you can then jog to the opposite end of travel and figure out where the limits will trip and set your softlimits to some value slightly less that the trip point.