Hello Guest it is November 12, 2019, 11:49:27 PM

Author Topic: Problem with SS driver 2.08  (Read 2432 times)

0 Members and 1 Guest are viewing this topic.

Offline 4z7

*
  •  16 16
    • View Profile
Problem with SS driver 2.08
« on: March 11, 2011, 05:40:36 PM »
I have been using SS for a couple of years now. I am generally satisfied with SS performance and I don't want to appear critical of SS. I prepared the following and sent to support@warp9td.com a few days ago but never received back any acknowledgement.   I assume SS  support,  just like Mach support is forum based at this forum, so I decided to post here.  Please note that this condition was only tested on Win7 64bit


Condition:0   Machv042.36 & ss15 & FTDI driver 2.06 , Win7x64 - Operates normal (starting condition)   

 After update Mach to 3.043.022 Mach hung with ss15 and I believe SS driver was 2.06.  I updated SSdriver to 2.08  and plugin to v17 but Mach still hung  as reported in condition1, so I removed SS and connected it to a desktop machine.

Condition1:    Mach3.043.22 , ss17 or ss15 , FTDI2.08 will not load and Mach hangs.   Mach window is grayed out and mouse cursor is hour glass when on top.  Task  Manager won't end program but I can do a normal shutdown.  SS LED heartbeat is solid

When I first connected SS to the desktop, it was running Mach3.043.28 which is a current development version.  I installed the driver and plugin ss17. Mach hung condition1.   Installed Mach3.043.22 but Mach still hung.  Installed Mach3.042.36 and Mach loaded ss17 plugin and I discovered condition 2.  I loaded ss15 and condition 0 normal.  Note here that  I think I was still using FTDI2.08 and  that I got Mach3.042.36 and ss17 or ss15 to load.  BUT I am not sure.  

The following can happen with USB devices.  Plugin in to USBportA and the device  driver will load for the last driver plugged into USB portA.  Likewise for USBportB, etc.  So, if SS is plugged into USBPortA and is unrecognized (i.e. it has never been plugged into USBportA) you can install a new driver say FTDI2.08 or update driver to 2.08.  Plug SS into USBportB and it IS recognized ( i.e. it has been before plugged into USBportB) and windows will load the last driver used for the device like FTDI2.06.  So just because you updated the FTDI driver on one USB port  doesn't necessarily mean that in any other USB port the driver will always be the latest FTDI driver.  That is why if you plug in SS to a USB port that it has never been plugged into before it is unrecognized and you are asked to install a driver.


Condition:2    Mach v042.36 & ss17 Plugin will load.  I use my own joystick plugin and when jogging at 100% of max
or maybe commanding 1.05* Max Velocity ( analog +- of joystick)  SS will throw an error and halt mach "Err reported by SS. Flag register 81420000".  I thought it was my plugin, so I removed it.  With axis MaxVelocity at 50ipm I MDI commanded "g1x10F99" and motion started and moved maybe 33% of commanded and then threw the same error.  During any move, the axis velocity DRO is not very steady reading 48 49 46,etc.  Sometimes the DRO  will flash a velocity of like 200 or 500 or 5000 just before producing the err and a couple of times the error isn't  produced and axis will take off like go to 1000 within a couple of seconds.   I cannot repeat  the error with ss15. The same commanded move produces a  steady 48.7 +- .2  vel DRO and steady jogging by joystick.

Thinking that I had got Mach042.36, ss15  and FTDI2.08 to operate properly on the desktop I went to install SS back to the machine

After re-installing SS to the machine, which had Mach3.043.22 , ss17,and 2.08 ssdriver(i think); Mach started up correctly which previously had hanged as condition1.  I tested for the error condition 2 without the servos actually active so no motion was actually happening.  SS threw the same error in condition 2 so I decided to change the plugin back to v15. After doing so the Mach hung condition 1 no matter  what  version Mach or plugin.  I decided to pull the machine pc and connect to the internet.  After all, on the desktop I had a successful condition  and the only difference between the desktop and the machine operating system was Windows update hadn't been run on the machine's pc in maybe 1 year.


After 50 updates and win7 sp1 update, Mach would still hang and all my testing had left 10 different profiles none of which would work with ss. Another occurrence was::  with v15 plugin in the plugin folder, but mach started on PP, then enabled in Configure Plugins, and restart, the plugin would still be disabled on the next start.  Regardless when I'd create a new profile with ss15 and tried to load it,  Mach would hang.

I have no idea why I did not try to roll back the FTDI driver yesterday when this problem began after updating to Mach3.043.22.  Because Mach hung loading ss I assumed that ss had to be updated. After a day and a half of frustration, I rolled back the FTDI driver to v2.06.  which works  with Mach3.043.22 and ss15. Mach3.043.22  will boot with ss17 and ftdi2.06 but throws error condition 1.

Obviously there is an error between the FTDI2.08 driver and both SS plugins version 15 and 17. So in summary:

1.  SmoothStepperDriver2.08.02 which is FTDI2.08.02 driver does not work with Win7 64bit and Mach any version or plugin any version.
2.  SmothStepperDriver2.06  will load   any Mach version  or plugin .with Win7x 64
3.  SSPlugin_v17bd throws error described in Condition 2.
4.  SmothStepperDriver2.06 , Mach3.043.22, SSPlugin_Beta2_v015ogx2.ddl is reliable with Win7x64.

It should also be noted that the current version FTDI driver is 2.08.12 and that comments are "Interim bug fix release" so obviously there are bugs in 2.08.02

I hope this can help others that have reported Mach hang with a grayed out screen.
Kurt