Hello Guest it is October 22, 2019, 06:11:31 PM

Author Topic: CNC4PC C6 Spindle Control Problem - Mystified!  (Read 2167 times)

0 Members and 1 Guest are viewing this topic.

CNC4PC C6 Spindle Control Problem - Mystified!
« on: March 09, 2011, 10:32:07 PM »
Hi All,

I just purchased a CNC4PC C6 spindle control board.  Everything is hooked up ok, and I can operate the spindle (turn on/off, increase/decrease speed) using the "Spindle CW F5" button, and the + / - buttons. The CW Relay clicks, voltage increases up and down (0-10v) just fine.

However, it just wont work when using the MDI input, or commands from a program file.  The relay wont click, and voltage wont change.  Typing "M03 S500" doesn't do anything.  I tried disabling the spindle CW/CCW relays, and setting them to be the Flood/Mist relays instead, and I could activate/deactivate them using the M7, M8, M9 commands.

Everything appears to be setup & enabled correctly. Like I said the spindle control buttons work 100% fine, and all other codes work fine (from programs or MDI - G0/G1 moves etc) - Just not spindle related ones.   ???

Just updated Mach to the latest R3.043.022 "Lockdown" version, but the problem persists.

Anyone have any suggestions?  

Cheers!

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: CNC4PC C6 Spindle Control Problem - Mystified!
« Reply #1 on: March 10, 2011, 04:14:09 AM »
Are you calling an M3 or M4 from code/MDI as well as the spindle speed?
Hood

Offline poppabear

*
  • *
  •  2,233 2,233
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: CNC4PC C6 Spindle Control Problem - Mystified!
« Reply #2 on: March 10, 2011, 08:47:01 AM »
   
for M3, M4 and M5 to work from the G code or MDI line, under ports/pins, under the spindle tab, you need to ENABLE the M3 and M4 relays, IF you have the option, I would put M3 on Output1, and M4 on Output2, and set the port/pin for each of the outputs respectively. If you disable the M3/4 relays under the spindle tab, then the Spindle CW/CCW LEDs dont work, nor does it output a change via the Gcode/MDI line.

scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/