Hello Guest it is November 14, 2019, 11:12:52 AM

Author Topic: Driver stops responding?  (Read 2589 times)

0 Members and 1 Guest are viewing this topic.

Offline ethos

*
  •  12 12
    • View Profile
Driver stops responding?
« on: March 02, 2011, 11:04:46 AM »
I was having problems with my original PC periodically locking up solid whilst running Mach3, so I have built a new box.

I am using an Intel Atom D525 @ 1.8GHz on a Gigabyte GA-D525TUD board with 4GB RAM and have switched from XP on the old machine to Win 7 32-bit.

I installed a clean copy of the current lockdown version of Mach3 (022).

I have turned off all power saving settings I can find.

The driver test program shows 'excellent' at all pulse rates. I set up Mach3 at 25KHz for soak testing.

I left Mach3 idle on the Diagnosics tab for an hour and then noticed that the 'time in int' value had stuck at +6.9. It was oscillating a couple of points either side of 7 previously.

Mach3 was still responsive to screen input and I could load G-code, but the DROs would not change value in response to jogging or code.

The test environment is a clean install with no extra plugins. It is configured for the parallel port, but nothing is plugged into the port at this stage.

Looks as though something causes communication with the driver to stop?

Terry

Offline fast89

*
  •  137 137
    • View Profile
Re: Driver stops responding?
« Reply #1 on: April 14, 2019, 04:57:03 PM »
I have seen this many times on many different computers.  All windows 7 32 bit with parallel port. I have yet to see a solution to it.

Offline reuelt

*
  •  444 444
    • View Profile
Re: Driver stops responding?
« Reply #2 on: April 20, 2019, 05:56:24 PM »
I was having problems with my original PC periodically locking up solid whilst running Mach3, so I have built a new box.

I am using an Intel Atom D525 @ 1.8GHz on a Gigabyte GA-D525TUD board with 4GB RAM and have switched from XP on the old machine to Win 7 32-bit.

I installed a clean copy of the current lockdown version of Mach3 (022).

I have turned off all power saving settings I can find.

The driver test program shows 'excellent' at all pulse rates. I set up Mach3 at 25KHz for soak testing.

I left Mach3 idle on the Diagnosics tab for an hour and then noticed that the 'time in int' value had stuck at +6.9. It was oscillating a couple of points either side of 7 previously.

Mach3 was still responsive to screen input and I could load G-code, but the DROs would not change value in response to jogging or code.

The test environment is a clean install with no extra plugins. It is configured for the parallel port, but nothing is plugged into the port at this stage.

Looks as though something causes communication with the driver to stop?

Terry

Have you done this patch?
https://www.machsupport.com/forum/index.php?topic=38269.0
"the gift of God is eternal life through Jesus Christ our Lord"

Offline fast89

*
  •  137 137
    • View Profile
Re: Driver stops responding?
« Reply #3 on: May 07, 2019, 07:13:21 PM »
The patch does not fix it. After 20 min or so sitting idle, mach3 stops responding and the Time in Int. on diagnostics page is locked and no longer reading variation. I've tried older versions 3.043.037 as well as 3.042.020 and it still locks. However, R2.63 does not lockup. This is on Windows 7 Pro. This problem does not occur on Windows XP.

Offline reuelt

*
  •  444 444
    • View Profile
Re: Driver stops responding?
« Reply #4 on: May 08, 2019, 03:19:18 AM »
1. The latest patched version is Mach3Version3.043.062(+Win 10 1803 patch) but on the
NFS download site it is just labelled as Mach3Version3.043.exe. That is the most stable version.

2. Is the parallel port set to EPP 1.7 at the BIOS?

3. Since the Parallel port is likely to be 3.3V version (because ITX motherboard with Atom CPU is power saving low voltage type), Can you try increasing the Step pulse to 15 and Dir pulse to 5 in motor tuning? If it works well then try decreasing to 10 and test again.
4. Screen saver - set to none. Windows sound set to none.
5. Disable Windows Update and superfetch services.
6.  Do you have a dedicated VIDEO card with at least 32MB ram? If not, you may have to turn off tool path display.
"the gift of God is eternal life through Jesus Christ our Lord"