Hello Guest it is October 16, 2019, 08:40:24 AM

Author Topic: Hesitation between Lines of G-code  (Read 8889 times)

0 Members and 1 Guest are viewing this topic.

Hesitation between Lines of G-code
« on: February 16, 2011, 02:18:06 PM »
I posted this on the yahoo group but figured I would try here as well.
I need some help. I built a JGRO wood router and am playing around with it
using Mach3 Mill. I am having a problem where the stepper motors are having a
slight hesitation between each line of g-code. It does not matter if it is a
circle or a straight line. If I write code for two straight lines connected to
each other I get a slight pause inbetween each line when I run the code. I have
tried it both with CV on and with exact stop on. It didn't make a difference.
I have backlash set to zero so I know it isn't a compensation issue. It is
almost like the computer takes a break from sending the pulses to the parallel
port each time the screen updates to the next line of code. The final dimensons
come out ok so I know it isn't actually loosing steps, it just makes the machine
run very jerky. I don't know if it matters but here are the details of my
setup.

Probotix bi-polar drivers with the non-isolated breakout board
256 oz/in powermax II bi-polar motors
1/2-10 acme threaded rod with dumpster anti-backlash nuts and lovejoy's
motor tuning 2000, 70ipm, accel 4, pulse width 2 - no microstepping
The program was drawn in autocad and cut2d was used as the cam program
Cutting at 35ipm and .200 depth per cut in mdf

Everything seems find with the setup except for the pauses between lines of
code. The machine jogs, rapids, and moves using MDI with no problems.

Any suggestions?


Keith

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Hesitation between Lines of G-code
« Reply #1 on: February 16, 2011, 02:41:17 PM »
You say you have backlash set to zero, does that mean you have it enabled? If yes then disable and see if it helps.
Hood
Re: Hesitation between Lines of G-code
« Reply #2 on: February 16, 2011, 03:56:44 PM »
No.  As far as I know, backlash is turned off.  I checked backlash with a dial indicator and it was under .001 so I didn't bother to turn it on in Mach3.  Even if it was turned on, it shouldn't make a difference with two straight lines in a row.  If I write a program that such as:

G01 X0 Y5 Z1
G01 X0 Y10 Z1

I wll get a slight pause when it goes from the 1st line to the 2nd one. 

Keith

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Hesitation between Lines of G-code
« Reply #3 on: February 16, 2011, 04:01:51 PM »
Can you attach your xml so I can see if I get the same issues.
Hood
Re: Hesitation between Lines of G-code
« Reply #4 on: February 16, 2011, 04:51:17 PM »
What is an xml?  Do you mean the g-code?

Keith

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Hesitation between Lines of G-code
« Reply #5 on: February 16, 2011, 04:53:56 PM »
xml is your config file, its located in the main Mach3 folder and will have the name of the profile you are using, so for example if using the standard Mill profile it will be called Mach3Mill.xml.
You will need to rename it for the forum to accept so copy it to your desktop and rename something like kmacht.xml and then use the additional options button on the reply page to browse and attach.
Hood
Re: Hesitation between Lines of G-code
« Reply #6 on: February 16, 2011, 05:41:15 PM »
Here it is.  I tried a few other settings quickly.  The amount of pause is directly proportional to the accel rate.  If I up the accel rate you can still hear the quick hesitation but it is alot harder to actaully feel.

Keith

Offline RICH

*
  • *
  •  7,367 7,367
    • View Profile
Re: Hesitation between Lines of G-code
« Reply #7 on: February 16, 2011, 06:57:32 PM »
Keith,
Try 7 for accel value for X & Y, and 3 for the Z.
RICH

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Hesitation between Lines of G-code
« Reply #8 on: February 16, 2011, 07:22:24 PM »
Make sure all CV options are turned off, but CV is on. Uncheck all the CV options in General Config, and turn off CV Distance and Feedrate on the settings page.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Hesitation between Lines of G-code
« Reply #9 on: February 17, 2011, 09:31:13 PM »
Kmacht, I want to piggy back on your post if you don't mind.

I have a similar problem. It manifests itself in the following way:
When cutting a circle, Mach generates two semi circles split across the y axis. Each semicircle is it's own line of code.
When the code moves from line to line their seems to be a pause, which creates a flat spot in the circle. I have just run this with a pen, rather than a router to make sure I am not having backlash/load problems. Flat spot and line change coincide.

I have some very slight dimension problems which could be explained by this issue as well.

Any thoughts?
Thanks,
Dan