Hello Guest it is July 11, 2020, 11:36:41 PM

Author Topic: THC not working properly  (Read 6036 times)

0 Members and 1 Guest are viewing this topic.

THC not working properly
« on: February 12, 2011, 07:54:02 PM »
basically, Mach3 is acting like the THC function is turned off, but it's not.  All of the THC related LED's light as they should, such at ArcOK, THC Up and THC down, but Mach does not respond.  ArcOK is completely ignored and THC Up and Down is not working even though the LED's indicate that these functions are working.  The system operates as if it's running a router.

The only thing different is that the ArcOK, THC Up and THC Down pins are mapped to modbus inputs.  I know they are mapped correctly because the LED's light.

Has anyone had issues with the Mach3 THC mode not working at all even though it is on and LED's function properly?

Thanks

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: THC not working properly
« Reply #1 on: February 13, 2011, 03:28:53 AM »
Is this a licenced or demo Mach3?
Re: THC not working properly
« Reply #2 on: February 13, 2011, 11:05:45 AM »
Licensed.  The THC function has been working fine.  I just switched over to a different THC that uses the modbus instead of a second PP.

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: THC not working properly
« Reply #3 on: February 13, 2011, 12:16:19 PM »
AFAIK, the required THC functionality is coded "inside" the PP driver. That's one reason why THC doesn't work with the smoothstepper for example. I suspect, that as you're using the modbus for these signals and therefore not using the PP, then you're suffering from the same problem.

Ian
Re: THC not working properly
« Reply #4 on: February 13, 2011, 01:56:30 PM »
But I can control virtually every aspect of Mach over the Modbus.  Why would the THC function be coded differently than everything else?  You can even select THC inputs in a brain...but unfortunately, those don't seem to work either.  Can't even get the LED's to light that way.

Just doesn't make sense that when I map a jog input or trigger some event with a modbus input it works, but when I map a modbus input to any of the 3 THC functions, I get nothing...Well, nothing but the LED's.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: THC not working properly
« Reply #5 on: February 13, 2011, 02:20:04 PM »
From my understanding THC and Probing are actually functions of the driver as they need the speed that only the driver can give in a PP connected system.


Hood

Oh also single point threading in Turn is also in the driver for a similar reason.
« Last Edit: February 13, 2011, 02:21:56 PM by Hood »
Re: THC not working properly
« Reply #6 on: February 13, 2011, 02:35:48 PM »
So there is no other way to drive THC functions other than a second PP?  And here I thought Art and Brian could walk on water. :(
Re: THC not working properly
« Reply #7 on: February 13, 2011, 03:06:09 PM »
Are the THC functions hard coded to the second PP or could an unused input on the primary PP be used?  The reason I ask is that if you use a stand alone THC that handles it's own motion control, the only input to Mach you would need is Arc OK, and it would be a shame to have to add a second PP just for that one input.  Any other communication, like the trigger to initiate torch reference, could be done through the modbus.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: THC not working properly
« Reply #8 on: February 13, 2011, 03:37:41 PM »
I dont know much about THC but I would be very surprised if the input was hard coded as nothing else in MACH is ;)

Hood
Re: THC not working properly
« Reply #9 on: February 13, 2011, 05:03:56 PM »
I've got it switched back over to PP control but I've still got nothing.  THC in Mach is definitely on.  I've got PP2 enabled and pin 15 mapped to Arc OK.  When the arc is good, the ArcOK LED lights so I know the mapping is good.

If I ground pin 15, the ArcOK LED lights.  If I then turn on the THC function in Mach, Mach should wait for an ArcOK signal before moving.  Forget about even having a THC connected.  If the THC function is on, Mach should wait for the ArcOK signal before moving, correct?   I should be able to put pin 15 on a button and Mach should wait until the button is pressed before moving.

The only difference between the profile I'm using for testing this and the profile I used with a Sound Logic THC is that in my mew profile I have modbus enabled, but as I said, I'm now controlling the THC through PP2.

What else is there that could cause Mach to ignore the THC commands?