Hello Guest it is November 14, 2019, 09:07:42 PM

Author Topic: Problem with the Z axis.  (Read 5661 times)

0 Members and 1 Guest are viewing this topic.

Problem with the Z axis.
« on: January 25, 2011, 11:32:52 PM »
Hi,
I hope you can shed some light on the last (known) problem on our router retrofit using Mach and the 7762M  Vital motion control box.

The Z axis is unreliable. it will run at up to about 700mm/min apparently reliably. The X Y and B (Tool Changer) are all workin fine.

With the Feed in exceess of this it will start then run at a much faster speed apparently for ever. Of course the Z axis travel is only 300mm so we quickly hit the stops.

It happens if the move is +ve or -ve direction.

We have been unable to improve this behavious except by running at very low speed.

It is not the drive or servo as we have swapped in replacements which did not elininate the problem.

Likewise we have eliminated the connector cable betwee the Vital systems box and the drive.


Our impression is that it is either Mach instructing the 7762 or the 7762 making a velocity output in excess of reasonable.

The position DRO's indicate normal and do not reflect the increased speed.

The servos and drives are FUJI and the operating system on the PC is XP

Currently we are stumped and would appreciate any comments and assistance

Thanks

Graham
Re: Problem with the Z axis.
« Reply #1 on: January 26, 2011, 12:17:00 AM »
hello Graham,

looks like the z pid setting is putting too much power and/or you have a very high value in the following error.  check that P is not too high. If you have some value in I term, make sure you have max_error_I to limit the integral error.

also, have you enabled debounce on the encoder signals?  this will make sure noise is not corrupting encoder counters.

hope this helps.

regards,
Rufi
Re: Problem with the Z axis.
« Reply #2 on: January 26, 2011, 01:21:09 AM »
Hi Rufi,
We are using the settings listed in the manual. Its hard to get a feel for what the numbers should be when we cannot run the axis.

Any better numbers to start with would be a help?

Regards

Graham
Re: Problem with the Z axis.
« Reply #3 on: January 26, 2011, 01:41:21 AM »
Hi Rufi,
One other area we are wondering about.
The Fuji servo drive is set upand wired in Torque mode. Velocity mode is available but I will need to rewire the cable and set the drive for this.

As it was in Torque mode we followed suit.

You may be able to advise if this is an issue or what/when does one choose Torque or Velocity mode?

Regards

Graham
Re: Problem with the Z axis.
« Reply #4 on: January 26, 2011, 04:50:51 AM »
Hi Graham
Make sure that the following error is set to a number above zero. If not it will give the symptoms that you mention.


Mike
We never have the time or money to do it right the first time, but we somehow manage to do it twice and then spend the money to get it right.
Re: Problem with the Z axis.
« Reply #5 on: January 26, 2011, 09:34:06 AM »
hi Graham,

Mike is correct,  make sure MFE is non zero.  in the manual there is section about it.

for tunning, start with scale 1000 and P 100, MFE at 5000, low pass at 5.  all others at zero.   do test motions.  if no motion observed, start increasing P until you see motion.   If the actual motion is in the opposite direction of commanded, change the encoder polarity in the system tab.  once you get a decent graph, (ie acutal folows commanded), start adding I and D and VFF terms to fine tune the graph, ie actual should be as close to commanded as possible.  when you set I term > 0, make sure Max error I should also be non zero, otherwise you will get uncontrolled oscillations. eg start I with 10 and max_error_I as 50, and gradually increase.   Do the test motions for small and large moves, ie few mm to 100 of mms.

As far as I know, velocity mode requires tacho feedback from motor to drive, while in torque mode, there is no such requirement.  If speed feedback is already builtin in your motor/drive setup, you can try both modes and see which gives the best performance.  I know some people are using torque mode with no problems,  although they tell me that torque mode is more difficult to tune than velocity mode.

I hope to update the manual soon based on your feedback.  did you get my email few days ago for slave axis setup?

regards,
Rufi


Re: Problem with the Z axis.
« Reply #6 on: January 26, 2011, 01:09:50 PM »
Hi Rufi,
Thanks for reply. We are leaving shortly for site and by end of day hope to have all working. Its only the Z axis we have issues with. The X, Y and B(tool changer) all appear to be working fine.

OK on Manual. I guess you have heard it before but the manual is important to us initiates and I do not mind sending back constructive comments to assist you from an end user.

Re e-mails.  No nothing on homing from you.  It seems that only Skype and the Forum are working for you/me. My e-mail addresses are not receiving any msgs from you.

Forum is OK maybe a little public but working. Skype is also fine I can use it on site which may be a bonus!!

Regards

Graham
Re: Problem with the Z axis.
« Reply #7 on: January 26, 2011, 01:31:32 PM »
here is part of the email I sent you earlier:
------------------------------------------------

you can connect the analog outputs as you suggested  X =0 Y=1 Z=2 A=3
 
make sure you set the slave axis in mach3.
 
and also in the plugin config window, set the input source index for the salve axis equal to master axis.
 
eg if A is slave of X, set the input index to 0 for A.  For all other axis, input index should be equal to axis number.
 
Axis Input Index
x      0
y      1
z      2
a      0
 
for the slave, you may have to set the input gain to +1 or -1 if it is moving opposite to the master axis.
 
for the rest of axis (b..e), input and output should be set to undefined.
 
only tune the master axis.
 
yes, the A axis become invisible and the two axis’s are tune together when you tune the master. when you do test moves,  only execute motion in the master axis.  slave will move automatically.  the PID setting of slave will be taken from master axis pid setting. so you donot need to put anything in the slave pid settings.
 
once you put everything in the plugin config tabs, hit OK and close mach3.  this will make sure all config is saved.  then restart mach3 and do tuning and testing.
 
....