Hello Guest it is August 18, 2019, 10:14:47 PM

Author Topic: Mach 3 Spindle rpm inaccurate  (Read 12966 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Spindle rpm inaccurate
« Reply #10 on: January 15, 2011, 07:49:20 PM »
Just noticed you said 42.04 version of Mach, try the latest as I am not sure if that version had the threading fixes.
Hood

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Spindle rpm inaccurate
« Reply #11 on: January 15, 2011, 07:52:02 PM »
Disregard my last post, just realised yu will be meaning 042.040.
Driver version sounds old though, will just go check

Hood

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Spindle rpm inaccurate
« Reply #12 on: January 15, 2011, 07:53:34 PM »
No driver version is the latest so you should be fine.
Hood
Re: Mach 3 Spindle rpm inaccurate
« Reply #13 on: January 15, 2011, 07:55:38 PM »
2" single pulse disk with a slot with of .2"

 
Mach3 R3.042.040 is the Lockdown version I'm using.

Mach3 R3.043.022 is still in Development and was not sure if i should try it until this
problem was resolved.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Spindle rpm inaccurate
« Reply #14 on: January 15, 2011, 08:03:53 PM »
No that version is fine, you had said 3.042.04 and I was thinking that was old but then realised after I posted you were meaning 3.042.040.

Dont really remember what the specs in the manual for spindle pulley and slot is but when I used the PP I always had about 100mm dia and 10mm slot so wondering if that could be your problem?

Did this work previously with an older version or have you just set it up?
Hood
Re: Mach 3 Spindle rpm inaccurate
« Reply #15 on: January 15, 2011, 08:13:11 PM »
I just set it up for the first time.

has any one had problems with the new changes or had to revert to a older
version?

should this work fine with my computer? (specs in first post.)

Did the new changes after 3.042.031 ( 032 to now ) knock out some
motherboards from using the index rpm feature?

I'm Stumped as to why it's not working right.

Richard

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Spindle rpm inaccurate
« Reply #16 on: January 15, 2011, 08:15:50 PM »
No should be working fine, cant recall anyone having issues other than when they had Index Debounce too high. Just wondering if its anything to do with MaxCL mode as I know pins get hard set in Mach when using the Max NC mode so may be the same for CL.
Hood
« Last Edit: January 15, 2011, 08:24:29 PM by Hood »

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Spindle rpm inaccurate
« Reply #17 on: January 15, 2011, 08:20:20 PM »
It does seem the pins are set for MaxCL mode as well, it says  pin 15 has nothing assigned but wondering if that means it cant be used or not. Afraid I know nothing of the MaxCL machines :(
Hood
Re: Mach 3 Spindle rpm inaccurate
« Reply #18 on: January 15, 2011, 08:27:43 PM »
The spindle on the MaxNc uses  pwm to switch the spindle motor on an off as a variable speed control.

By switching a electronic rely vary fast, you can have mach 3 control the speed of the spindle.

Could this be interfering with the rpm counts?

Just took mach out of MaxNc mode, tried it.

results: no change

put mach back in MaxNc mode.

On the mill control board, pin 15 is not connected to anything or any circuit traces.
It's a unused pin.

Any Ideas hood?

Richard
« Last Edit: January 15, 2011, 08:31:14 PM by KB7CGA »

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 Spindle rpm inaccurate
« Reply #19 on: January 15, 2011, 08:33:15 PM »
No, afraid I dont have any ideas , only thing I can think of is going direct to the port, if possible, with the index rather than going through any boards (presuming you have some sort of BOB/Interface)
Other thing is the slotted pulley size as mentioned earlier but think that would make the spindle speed show slower if the pulse wasnt seen correctly due to the pulley/slot being too small.

Hood