Hello Guest it is October 27, 2021, 06:59:24 PM

Author Topic: "probe tip diameter is invalid"  (Read 8711 times)

0 Members and 1 Guest are viewing this topic.

"probe tip diameter is invalid"
« on: January 10, 2011, 07:55:53 PM »
Hi,

Been using Mach3 for many years first with a Taig and recently with a Tormach.  I recently purchased a used Marposs Probe to replace an econo probe I had for years.  The Marposs probe came with a probe tip that is 0.2755" dia.  But when I put input this into tool #99, the message of "probe tip diameter is invalid " comes up when I try to probe the vise.  I can probe X, Y or Z just fine but not the vise.  Can anyone help?

Thanks!

Ken Wu

Offline BR549

*
  •  6,952 6,952
    • View Profile
Re: "probe tip diameter is invalid"
« Reply #1 on: January 10, 2011, 08:19:58 PM »
Are you using the tormach system? If so then it is different from a standand mach setup.A standard Mach ssetup does NOT use Tool#99 for tip comp. There is a setting on one of the pages that comps the tip and then ONLY to comp the saved points files.

(;-) TP
Re: "probe tip diameter is invalid"
« Reply #2 on: January 10, 2011, 08:38:34 PM »
Yes,  I am using the Tormach provided version of Mach3.  I thought they were pretty similar with some addons and pre-configed for Tormach.

As for the special screen you are talking about, is it the offset screen?  If so... the offset screen still updates the tool table... right?  Tormach recommends using Tool #99 for probe but you can pretty much use any # you wish.

Thanks for your help... I might have to give Tormach a call... was hoping to get it working tonight.

Ken
Re: "probe tip diameter is invalid"
« Reply #3 on: January 11, 2011, 03:11:21 PM »
It seems the probe tip parameters are set in the Tormach screen set.  Just found in PCNC1100M3-W.set where it sets the min and max for probe diameter.

If ProbeDia <0.1 OR ProbeDia > 0.25 Then
Message "Probe tip diameter is invalid"

But when I tried changing the 0.25 to 0.30 and restart Mach... it crashes with a white screen (tool bar on top still there... can click on it, load a file but the main screen remains white... when I try to exit... Mach crash message pops up)

Anyone know how to change the screen set correctly?

Ken

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: "probe tip diameter is invalid"
« Reply #4 on: January 11, 2011, 03:25:45 PM »
Can you attach the screenset please.
Hood
Re: "probe tip diameter is invalid"
« Reply #5 on: January 11, 2011, 03:41:04 PM »
Thanks Hood... attached is the screen set.  There are 5 places where the ProbeDia comes up and I tried changing all 5 to > 0.30 but as soon asI make any changes... Mach will crash.  

Thanks for helping.

Ken

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: "probe tip diameter is invalid"
« Reply #6 on: January 11, 2011, 04:53:01 PM »
Do you have the bitmaps for that screenet or a link to the download as I dont see half the screen.
Hood
Re: "probe tip diameter is invalid"
« Reply #7 on: January 11, 2011, 05:02:30 PM »
Attached is the bitmap folder.  Thanks!

Ken

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: "probe tip diameter is invalid"
« Reply #8 on: January 11, 2011, 05:12:05 PM »
Where is the probe dia set up, must be getting short sighted ;D

Hood
Re: "probe tip diameter is invalid"
« Reply #9 on: January 11, 2011, 05:17:38 PM »
Took me a while to find it as well... I ended up using Search on notepad and searched for Probe Tip.  This is a cut and paste from the first one... the other 4 is very similar.

If DistToLook < 0 Then DTLSign = -1.0 Else DTLSign = 1.0

UserTool = GetOEMDRO (824)
SetOEMDRO 824, 99   ' select probe
ProbeDia = GetOEMDRO (43) / Mmm    ' stored in inches
SetOEMDRO 824, UserTool   ' revert to users tool

If ProbeDia < 0.01 OR ProbeDia > 0.25 Then
    Message "**** Probe tip diameter is invalid"
    Exit Sub
End If


Ken