Hello Guest it is July 19, 2019, 11:15:08 AM

Author Topic: Can't get the spindle/pulley calibration figured out  (Read 11719 times)

0 Members and 1 Guest are viewing this topic.

Offline Vogavt

*
  •  258 258
    • View Profile
Can't get the spindle/pulley calibration figured out
« on: January 01, 2011, 02:51:39 PM »
Using Mach 3, Version R3.042.020
Using xylotex XS-3525/8S-4
Using cnc4pc C11 board
Using Harbor Freight Mini-Mill (44991) with stock DC motor


I'm attempting to calibrate the spindle speed after discovering the speed was way off following the purchase of a hand-held tachometer.

Checked the "Spindle Pulleys" from the Configuration Drop down.
      Set to Pulley Number 1, min 500, max 1800, ratio 1
      Select Okay

Went to the settings tab and verified on Pulley 1.

Went to Function Cfg's, Calibrate Spindle
      Set the control to 500
      Pressed Spindle on/off and checked speed with tachometer
      Getting a reading of 2000 rpm!

Went back to "Spindle Pulleys" from the Configuration Drop down.
      Changed the ratio to 0.25
      Select Okay

Went to Function Cfg's..> Calibrate Spindle
      Set the control to 500
      Pressed Spindle on/off and checked speed with tachometer
      Still getting a reading of 2000 rpm!

I've restarted Mach3, I've saved settings, etc., but I can't seem to get the changes to take place.

Not sure how the AutoCal works since I don't have any feedback to system regarding RPM. I did note that when selecting AutoCal the software does in fact cause the speed to increase gradually, but I always stop before it ends due to the latter reason.

On the motor tuning of the spindle, I have:
      Steps per:  1000
      Velocity:     1500
      Accel:        161.25
      Step Pulse: 4
      Dir Pulse:    4

Odd thing is, I can't change the Velocity. I can type in new numbers but when I click somewhere else on the dialog, the number reverts to 1500.

On the Ports and Pins, Spindle Tab:
      Motor Control is set to Use Spindle Motor Output and Step/Dir. If I disable it, I can't get the spindle to turn at all.
     "ModBus Spindle - Use Step/Dir as well" is disabled
     "Special Functions - Use Spindle Feedback in Sync Mode" is disabled

Any help would be appreciated!

Happy New Year 2011,
Vogavt
« Last Edit: January 01, 2011, 03:00:35 PM by Vogavt »

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Can't get the spindle/pulley calibration figured out
« Reply #1 on: January 01, 2011, 03:00:45 PM »
Can you attach your xml please.
Hood

Offline Vogavt

*
  •  258 258
    • View Profile
Re: Can't get the spindle/pulley calibration figured out
« Reply #2 on: January 01, 2011, 03:09:15 PM »
See attached.

Thanks!

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Can't get the spindle/pulley calibration figured out
« Reply #3 on: January 01, 2011, 03:20:46 PM »
Ok first thing is the reason you cant get a higher velocity than 1500 is because you are running the kernel at 25KHz and with a step per unit of 1000 that equates to a max velocity of  25000/1000 = 25 units per second or 1500 units per minute.

What kind of motor do you have for the spindle?
Hood

Offline Vogavt

*
  •  258 258
    • View Profile
Re: Can't get the spindle/pulley calibration figured out
« Reply #4 on: January 01, 2011, 03:31:04 PM »
Stock Harbor Freight mini-mill DC motor, which is rated to 6000 rpm.

I am actually able to get the spindle to turn to 4600 rpm, but didn't want to push that high for any duration.
This is with the mill in high gear and telling the spindle calibration to run at 1750 rpm (yields 4600 rpm on spindle).

Which brings me to another point. I want to be able to select either gear speed and then tell Mach which "pulley" I'm using and the numbers come out right when I give it a M3S??? code.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Can't get the spindle/pulley calibration figured out
« Reply #5 on: January 01, 2011, 03:32:53 PM »
What speed control board do you use?
Hood

Offline Vogavt

*
  •  258 258
    • View Profile
Re: Can't get the spindle/pulley calibration figured out
« Reply #6 on: January 01, 2011, 03:33:39 PM »
Also, I modified my original post and provided some additional information since I first posted it. You may need to reread it. Sorry, just trying to capture everything here for future reference.

Offline Vogavt

*
  •  258 258
    • View Profile
Re: Can't get the spindle/pulley calibration figured out
« Reply #7 on: January 01, 2011, 03:35:42 PM »
What speed control board do you use?
Hood

Icon Health & Fitness Inc. From Surplus Center (tread mill controller): Model MC-60

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Can't get the spindle/pulley calibration figured out
« Reply #8 on: January 01, 2011, 03:46:39 PM »
I have no experience with anything other than true Step/Dir spindles but will try and help.
When you command max speed what voltage do you get from the CNC4PC board?
Hood

Offline Vogavt

*
  •  258 258
    • View Profile
Re: Can't get the spindle/pulley calibration figured out
« Reply #9 on: January 01, 2011, 03:52:02 PM »
Just to make sure I don't blow something, do you know where I'm supposed to take that measurement?

I would assume what's coming out of the controller, but since you reference the cnc4pc - c11 board I'm confused.