Hello Guest it is February 21, 2024, 10:34:46 PM

Author Topic: Galil 40x0 issues:  (Read 3321 times)

0 Members and 1 Guest are viewing this topic.

Galil 40x0 issues:
« on: December 29, 2010, 07:10:46 AM »
Hi,
Plugin nearly works perfectly however have the following questions/requests:

In LI mode the plugin use VT command which has been superceded by IT I believe. Any chance this can be updated?

How do the burnt settings on the controller affect the settings in mach3?
eg max velocity,acceleration,deceleration? Are these values overridden by the Mach motor tuning values?

I have a gantry where the second X motor (B axis) has to run in the reverse direction and so a gearing value of -1 needs to be applied. The plugin only sets a gearing of 1. Can I burn the correct gantry settings and they will be used (if i dont slave axes in Mach)
Thanks


Offline kcrouch

*
  •  193 193
  • In way too deep!!!
    • View Profile
Re: Galil 40x0 issues:
« Reply #1 on: December 29, 2010, 09:28:52 AM »
I can answer some of your questions.
Not sure about the VT vs IT, will look into it.
Any and all burnt settings may be overwritten by Mach as they are arrived at.
Your best choice for the B motor is to rewire it so that the direction reverses.

Servo motor run-away or direction reversal methods.
When the polarity of the encoder feedback is wrong, the motor will attempt to run away. The
controller should disable the motor when the position error exceeds the preset following error. If the
motor runs away, the polarity of the loop must be inverted.

Inverting the Loop Polarity:
When the polarity of the feedback is incorrect, the user must invert the loop polarity and this may be accomplished
by several methods. If you are driving a brush-type DC motor, the simplest way is to invert the two motor wires
(typically red and black). For example, switch the M1 and M2 connections going from your amplifier to the motor.
When driving a brushless motor, the polarity reversal may be done with the encoder. If you are using a single-ended
encoder, interchange the signal CHA and CHB. If, on the other hand, you are using a differential encoder,
interchange only CHA+ and CHA-.

Sometimes the feedback polarity is correct (the motor does not attempt to run away) but the direction of motion is
reversed with respect to the commanded motion. If this is the case, reverse the motor leads AND the encoder
signals.


Kenny
Having way too much fun! Something must surely be wrong.

Offline kcrouch

*
  •  193 193
  • In way too deep!!!
    • View Profile
Re: Galil 40x0 issues:
« Reply #2 on: December 30, 2010, 08:37:02 PM »
Version 4.4 of the plugin already strips out the VT commands when in LI mode. The earlier versions do not. Please update to the latest plugin when you can.
Kenny
Having way too much fun! Something must surely be wrong.