Hello Guest it is June 18, 2019, 11:58:16 AM

Author Topic: Bugs in Mach3  (Read 3572 times)

0 Members and 1 Guest are viewing this topic.

Bugs in Mach3
« on: November 06, 2006, 08:40:21 AM »
I have just started using Mach3 and have noticed a few bugs.

#1 The pins setting, motor tuning, limits, etc are not saved when you hit save. That is if you change something and then Mach3 crashes your saves are not there.

#2 The emergency stop pin can not be disabled. It was configured to be same pin as one of my limit switches by default and for all the world I could not turn it off. I finally changed it be on port 0.

#3 Random settings in limits setting, sometimes I have found I have to click home negative 3-4 times before it will accept setting. What happens is that I set it to be negative save settings exit, then test on mill where things do not work, go back and find the settings were not saved.

#4 DXF import is not great. The DXF import does a poor job of optimizations, also I had put some cuts in the DXF to mill out a pocket, the DXF import made these cuts diagonal even though they should have been straight.

Please don't get me wrong Mach3 is great. I just wanted to post these bugs as form of payment for a wonderful product!

Trampas

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: Bugs in Mach3
« Reply #1 on: November 06, 2006, 11:14:36 AM »
Hi, Trampas

#0 What version of Mach3 ?
#1 After changing Item's, Re-start Mach3, XML setting's are saved.
#2 Have you try-ed changing the Emulated to Checked in Port's Pin's Inputs, 0 port, 0 pin work's to.
#3 What is the processor speed of your computer ?, Try setting the Performance Options Advanced to Background Services in Window's.
Start, Control Panel, System, Advanced, Performance,Setting's,Advanced, Performance, Background Services, Checked then Apply, OK.
#4 Update to Mach3R2.0.008 try LazyCam, File,Lazycam.

Hope this Helps, Chip
Re: Bugs in Mach3
« Reply #2 on: November 06, 2006, 01:53:21 PM »
I am using Mach3 Release 1.84.002, which I guess I need to update.

I figured out that I had to save and restart Mach3 for the settings to get saved to file. I had expected they would be saved to file when exiting dialog box.

The computer is an old laptop Pentium II 450 Mhz, which may not be fast enough.

I will updated to R2.0.0008, what is lazyCam?

Trampas


Offline Chaoticone

*
  • *
  •  5,504 5,504
  • Precision Chaos
    • View Profile
Re: Bugs in Mach3
« Reply #3 on: November 06, 2006, 02:00:36 PM »
Lazy cam is a cam package. Use it to generate GCode. I think you can import a DXF into it. All of this for $150.00. This is a miracle. ;D
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: Bugs in Mach3
« Reply #4 on: November 06, 2006, 02:31:40 PM »
Hi, Trampas

450 Mhz is probally why your having some problems, I've run Mach3 on a 666 Mhz comp it ran but was very slow when changing things in config menu's.

You really need something in the 1000 Mhz or faster.

Thank's, Chip
Re: Bugs in Mach3
« Reply #5 on: November 06, 2006, 06:26:21 PM »
When you are setting up your machine please set keep exiting the program when you have a setting that you like. The problem is that we can only save the XML on exit :(
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com